Bug 94183 - LibreOffice recovery wizard initiated when trying to run as administrator and as normal user at the same time
Summary: LibreOffice recovery wizard initiated when trying to run as administrator and...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Recovery
  Show dependency treegraph
 
Reported: 2015-09-13 09:31 UTC by János Néhrer
Modified: 2019-10-09 14:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description János Néhrer 2015-09-13 09:31:39 UTC
Environment:
- Windows 8.1 x86-64 English
- Administrator user
- UAC set to "Ask when an application tries to make changes..." (default value)
- LibreOffice 4.4.x or 5.0.1 (many other versions affected as well) installed
- Total Commander (or other file manager) run as administrator

Steps to reproduce:
1. Open a document using the Total Commander.
2. Try to open another document using Windows Explorer.
3. Wait a few seconds (nothing happens, LibO document remains open and unchanged).
4. Close LibreOffice window.

Result: LibreOffice recovery wizard starts.

Explanation:
During step 1, LibreOffice starts as admin and opens the document.
During step 2, Windows shell tries to start LibO as normal user. However it is already running as admin.
LibreOffice (or Windows?) is unable to handle this (nothing happens in step 3), but it doesn't crash this time.
When closing LibO (step 4), it realizes, that it didn't started or stopped properly. Wizard starts.

Expected behavior: LibO should either pass the new document to the already running process, or it should show a dialog that LibO is already running in another user space and it should not try to open the document.

Fact: Issue can be reproduced using any LibreOffice component (Calc/Write/Impress/Draw...)

Please note this has not been tested in terminal server environment (where users with different security levels may work in parallel).
Comment 1 Buovjaga 2016-12-20 12:51:09 UTC
Repro with Total commander https://www.ghisler.com/

Version: 5.2.4.1 (x64)
Build ID: 9b50003582f07ac674d6451e411e9b77cccd2b22
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 2 QA Administrators 2018-10-08 02:47:45 UTC Comment hidden (obsolete)
Comment 3 János Néhrer 2018-10-08 05:01:13 UTC
Issue still reproducible in LibreOffice 6.1.2

Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: hu-HU (en_US); Calc: group threaded
Comment 4 QA Administrators 2019-10-09 02:29:44 UTC Comment hidden (obsolete)
Comment 5 János Néhrer 2019-10-09 14:14:05 UTC
Can't reproduce using the version below on Windows 8.1 x86-64 English.

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (en_US); UI-Language: en-US
Calc: threaded