Bug 94196 - FILESAVE, FILEOPEN: .xlsx: TRANSPOSE formula is corrupted after saving and reopening file.
Summary: FILESAVE, FILEOPEN: .xlsx: TRANSPOSE formula is corrupted after saving and re...
Status: RESOLVED DUPLICATE of bug 61908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-13 18:40 UTC by Alexander
Modified: 2015-09-14 14:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file with TRANSPOSE() example (9.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-13 18:40 UTC, Alexander
Details
Sample modified (12.64 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2015-09-13 22:05 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2015-09-13 18:40:56 UTC
Created attachment 118678 [details]
Test file with TRANSPOSE() example

Hello,

I've found a bug with the TRANSPOSE function in Calc for the .xlsx file (with .ods this bug is not present). I've attached the file "Test_TRANSPOSE.ods". You can see the original array D2:H2 and transposed array B4:B8. 

Let's try to save this file to .xsls, close the file, and then open .xlsx file again. At first sight, the transposed array is in place, with the correct values. But look at the formulas in the cells B4:B8 :

Must be: "{=TRANSPOSE(D2:H2)}" for all cells B4:B8
Really are: "=TRANSPOSE(D2:H2)" for B4; "=B4" for B5:B8

I've noticed the values of the original array are saved correctly in the transposed array in spite of the formulas that are now corrupted. You can save the file and open it again many times - the values of the original array will be displayed correctly. This makes the bug rather dangerous, because you will not be able to see the bug until..

..until you won't make change to the original array. Let's edit the cell E2: enter "6" instead of "2". Look at the transposed array: all 5 cells are updated with the value "1" (as per corrupted formulas).
Comment 1 raal 2015-09-13 18:53:58 UTC
I can not confirm Verze: 5.0.1.2 (x64)
ID sestavení: 81898c9f5c0d43f3473ba111d7b351050be20261, win7
and Version: 5.1.0.0.alpha1+
Build ID: dd0ceb50c2d95ac0587db2c983ac58f2e3b13028
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-09_04:41:21

Seems to be fixed. Please test newer version, http://www.libreoffice.org/download/libreoffice-fresh/
Thank you
Comment 2 Alexander 2015-09-13 20:51:16 UTC
I've checked it with LO 5.0.1.2 - the results are the same as the described earlier (the bug is present). Did you do your tests with .xlsx file? (the example file is .ods for the integrity of the formula).
Comment 3 MM 2015-09-13 21:45:42 UTC
Confirmed with v4.4.5.2 under windows 7 x64.
Confirmed with v5.0.2.1 under mint 17.2 x64.

After a roundtrip to xlsx, B5 to B8 is indeed set as =B4 and B4 is set as =TRANSPOSE(D2:H2)
Comment 4 m.a.riosv 2015-09-13 22:05:24 UTC
Created attachment 118684 [details]
Sample modified

Please @raal test with attached file, saving it as xlsx and opening generated file.

Reproducible.
Win10x64
LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1
AOo 4.1 (Only read)

I think the issue is opening the file, because looking into the generated xlsx, TRANSPOSE function is there on the five cells.
Comment 5 Alexander 2015-09-14 09:02:20 UTC
(In reply to m.a.riosv from comment #4)
> I think the issue is opening the file, because looking into the generated
> xlsx, TRANSPOSE function is there on the five cells.

I think it needs additional consideration, because after saving this file as .xlsx, closing it, and opening _with MS Excel_ - the formula seems to be already corrupted. I have tried to do it with MS Excel 2010 SP2.
Comment 6 m.a.riosv 2015-09-14 14:37:43 UTC
You are right @Alexander, my mistake, I confuse the values that I add in C and D, with the formulas in B.

Reproducible with:
LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1

The issue it's not only with TRANSPOSE() function, but with all arrays.

Resolved as duplicate, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 61908 ***