Bug 94284 - Calc does not export Charts to XLS with axis set to start or end (see Comment 8)
Summary: Calc does not export Charts to XLS with axis set to start or end (see Comment 8)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: filter:xls
Depends on:
Blocks: Chart XLS
  Show dependency treegraph
Reported: 2015-09-16 17:41 UTC by Ilya
Modified: 2023-02-26 03:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

File to reproduce the problem (7.00 KB, application/vnd.ms-excel)
2015-09-17 08:37 UTC, Ilya
Set to 2 (7.00 KB, application/vnd.ms-excel)
2015-09-17 09:09 UTC, Luke
XLS scatter chart set to "Maximum Axis Value" saved by Excel (30.00 KB, application/vnd.ms-excel)
2015-09-18 02:16 UTC, Luke
XLS scatter chart set to Automatic(Start?) saved by Excel (30.00 KB, application/vnd.ms-excel)
2015-09-18 02:19 UTC, Luke
Native ODS. To Reproduce Save As .xls (14.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-04 02:30 UTC, Luke

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya 2015-09-16 17:41:52 UTC
I try to attach my X-axis to start or end of Y-axis. It attaches, but does not save in xls file format. So I can see the result, I can save file, but, when I will reopen it, it looks like before change.
Comment 1 Alex Thurgood 2015-09-17 08:02:24 UTC Comment hidden (obsolete)
Comment 2 Ilya 2015-09-17 08:37:59 UTC
Created attachment 118787 [details]
File to reproduce the problem
Comment 3 Ilya 2015-09-17 08:43:01 UTC Comment hidden (obsolete)
Comment 4 Luke 2015-09-17 09:09:27 UTC Comment hidden (obsolete)
Comment 5 Ilya 2015-09-17 09:15:27 UTC
My version is
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261

Yes, if I will set a value, then it will be fine.
But try to select "Start" or "End". It will reattach to the lower end of axis after reopening.
Comment 6 Alex Thurgood 2015-09-17 09:51:57 UTC Comment hidden (obsolete)
Comment 7 Alex Thurgood 2015-09-17 09:56:49 UTC Comment hidden (obsolete)
Comment 8 Luke 2015-09-18 02:13:59 UTC
There are a couple of issues here. First of all Excel does not have an exact 1-to-1 match for Axis crosses at "Start" and "End". Instead Excel has "Automatic" and "Maximum Axis Value". End seems to match closely to "Maximum Axis Value". However Start does not. For example when I created a scatter chart in Calc, set to start, exported it to XLSX, and opened it in Excel, Excel correctly displayed the chart with axis crosses at "Automatic" AND a value of -1.5(this is greyed out). When I saved as XLS, Excel gave the following warning:

"This file contained features which were not recognized by this version of Excel. These features will not be saved.

The resulting chart crossed at 0, not 1.5 when opened in Excel. Exactly like Calc does when it exports this chart. The difference is Excel sets it to automatic while calc sets it to 0. But the end result is the same.

The good news is End appears to be the same as "Maximum Axis Value" and the binary format does support both "Automatic" and "Maximum Axis Value". The exporter should be using these parameters instead of 0. I'll attach examples to be analyzed with a tool like oledump. 

For future reference, below is what you should have included in your original Description along with a sample document. This is how to write a good bug report.

The steps to reproduce are:
1. Create a XY (Scatter)
2. Edit the chart
3. Format axis -> Positioning -> Axis Line -> Cross other axis at  -> Select Start or Finish
4. Save as XLS
5. Close and reopen

Expected results:
Axis remains at start or finish

Actual results:
Axis set to value=0
Comment 9 Luke 2015-09-18 02:16:52 UTC
Created attachment 118814 [details]
XLS scatter chart set to "Maximum Axis Value" saved by Excel
Comment 10 Luke 2015-09-18 02:19:14 UTC
Created attachment 118815 [details]
XLS scatter chart set to Automatic(Start?) saved by Excel
Comment 11 Luke 2015-09-18 02:36:50 UTC
One more data point. The importer converts "Maximum Axis Value" to "End", while it converts "Automatic" to Value = 0. So our exporter should covert "End" to "Maximum Axis Value", but we should convert start to a Value=.
Comment 12 QA Administrators 2017-01-03 19:39:14 UTC Comment hidden (obsolete)
Comment 13 Luke 2017-01-04 02:30:11 UTC
Created attachment 130129 [details]
Native ODS. To Reproduce Save As .xls

Still not exporting correctly in Version: (x64)
Build ID: bf80bbb7b75febc2769d6b64e6981224982f8fe2
Comment 14 QA Administrators 2018-01-05 03:41:38 UTC Comment hidden (obsolete)
Comment 15 Luke 2018-02-13 19:09:39 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2019-02-14 03:49:07 UTC Comment hidden (obsolete)
Comment 17 Luke 2019-02-14 06:54:05 UTC
Still not exporting correctly in Version:
Build ID: 45f4de6d333aa3fa5873cf8e1146286c74960557
Comment 18 QA Administrators 2021-02-25 04:09:31 UTC Comment hidden (obsolete)
Comment 19 QA Administrators 2023-02-26 03:21:30 UTC
Dear Ilya,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team