Download it now!
Bug 94309 - SUMIFS function gives Err:504 for external references
Summary: SUMIFS function gives Err:504 for external references
Status: RESOLVED DUPLICATE of bug 115162
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Bartosz
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Function
  Show dependency treegraph
 
Reported: 2015-09-17 12:58 UTC by Javier
Modified: 2018-02-06 22:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (13.76 KB, application/zip)
2015-11-19 16:02 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Javier 2015-09-17 12:58:44 UTC
Related with https://bugs.documentfoundation.org/show_bug.cgi?id=64229

Hi there.

I'm using Calc Libreoffice Version: 5.0.1.2.0+ Build ID: 00m0(Build:2).

Steps to reproduce:

1. Create /tmp/a.ods with below data:

year month amount
2015 1 10
2015 1 20
2015 2 5

2. Create /tmp/b.ods with below function:

=SUMIFS('file:///tmp/a.ods'#$Sheet1.C2:C4,'file:///tmp/a.ods'#$Sheet1.B2:B4,1,'file:///tmp/a.ods'#$Sheet1.A2:A4,2015)

What I expect?

To get a "20" value

What I get?

Err:504

Tips:

-If I use the function assistant after fill the 1st parameter, I get Err:511
-If you use below function in "/tmp/a.ods" it works:

=SUMIFS(C2:C4,B2:B4,1,A2:A4,2015)
Comment 1 raal 2015-09-17 13:58:26 UTC
I can  confirm with Version: 5.1.0.0.alpha1+
Build ID: a60db559d409514fb93af0167c543ad2f852b499
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-16_01:09:20
Comment 2 raal 2015-10-22 14:01:06 UTC
Seems to be fixed in dev version, I can not reproduce with Version: 5.1.0.0.alpha1+ Build ID: 233b9b0ec95069b5ce98aab942304459ca7344a8, win7
and Version: 5.1.0.0.alpha1+
Build ID: 51df957e1a40d2f3511345c1600c05dd35f34b6b
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-19_04:22:32

Please could you test with dev version? You can download it here: http://dev-builds.libreoffice.org/daily/master/
Comment 3 Javier 2015-10-22 14:53:21 UTC
Many thanks for your time.

I will try it as soon as possible, but I don't think it will happen till next Monday.

Cheers.
Comment 4 raal 2015-11-19 10:29:50 UTC
Hello Javier, please could you test it? To be sure the bug can be closed. Thank you!
Comment 5 Javier 2015-11-19 11:06:55 UTC
Hi there, still same issue.

Steps I followed:

1. Remove stable Libreoffice installation

sudo apt-get remove --purge libreoffice-common

2. I installed suggested dev version of Libreoffice:

wget -c --tries=0 http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/current/master~2015-11-17_00.57.30_LibreOfficeDev_5.1.0.0.alpha1_Linux_x86-64_deb.tar.gz
tar xvfz master~2015-11-17_00.57.30_LibreOfficeDev_5.1.0.0.alpha1_Linux_x86-64_deb.tar.gzcd LibreOfficeDev_5.1.0.0.alpha1_Linux_x86-64_deb/DEBS/
sudo dpkg -i *.deb

3. Then I launched Libreoffice:

libreofficedev5.1 

Which displays below version number:

Version: 5.1.0.0.alpha1+
Build ID: 32d4c03cba399ada807b8ec113a3928aa9e3ff7b
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-11-17_00:57:30
Locale: en-US (en_US.UTF-8)

4. Then I repeated exactly the same steps outlined in my report, and I got identical result
Comment 6 Javier 2015-11-19 11:14:54 UTC
Just in cas is relevant I realize that I was missing JRE:

javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

Then I installed it:

sudo apt-get install default-jre

Then I re-open the file (b.ods) but same issue.

Do you think I should re-install Libreoffice dev again?
Comment 7 Javier 2015-11-19 11:22:23 UTC
I uninsalled and re-installed dev version and same issue
Comment 8 raal 2015-11-19 16:02:53 UTC
Created attachment 120666 [details]
test case

Sorry, I've accidentaly tested with test case from bug 64229.

Bug is still valid.
Comment 9 Javier 2015-11-19 16:04:30 UTC
Raal, it's ok, many many thanks for your time and great job
Comment 10 Tibor Kovács 2016-09-13 05:17:06 UTC
The bug is present in the nevest LO5.2.1 version too. (I have tried the Portable version only.)
The function SUMIFS() will not work with a reference to an another file.
The function results in error code 504. 
The AOO 4.1.2 can work in this case.

Tried with versions LO4.4.7, portable LO5.2.1
Locale: Hungary
Op. Sys: Win 7 prof 64 bit.
Comment 11 Tibor Kovács 2016-09-14 05:23:40 UTC
(In reply to Tibor Kovács from comment #10)
> The bug is present in the newest LO5.2.1 version too. (I have tried the
> Portable version only.)
> The function SUMIFS() will not work with a reference to an another file.
> The function results in error code 504. 
> The AOO 4.1.2 can work in this case.
> 
> Tried with versions LO4.4.7, portable LO5.2.1
> Locale: Hungary
> Op. Sys: Win 7 prof 64 bit.
Comment 12 Kruno 2017-10-15 14:07:14 UTC
Present in LO 5.3.6.1.
Comment 14 himajin100000 2017-10-17 15:50:30 UTC
oh sorry, when I took a look at commit log in bug 64229, the fix before this regression was already there. so it seems I ended up in making needless comment.
Comment 15 Bartosz 2018-02-06 01:14:18 UTC

*** This bug has been marked as a duplicate of bug 115162 ***
Comment 16 Bartosz 2018-02-06 01:29:36 UTC
It seems that solution from is not working:
https://gerrit.libreoffice.org/#/c/49264/1
Comment 17 Bartosz 2018-02-06 22:22:50 UTC

*** This bug has been marked as a duplicate of bug 115162 ***