Bug Hunting Session
Bug 94324 - in LibO install not full font OpenSymbol
Summary: in LibO install not full font OpenSymbol
Status: RESOLVED DUPLICATE of bug 76239
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-17 19:08 UTC by Roman Kuznetsov
Modified: 2015-11-26 15:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LO Math Element bar with not correctly special symbol (7.65 KB, image/png)
2015-09-17 19:08 UTC, Roman Kuznetsov
Details
Font from LO install (196.73 KB, application/x-font-ttf)
2015-09-17 19:08 UTC, Roman Kuznetsov
Details
Font from third-party (198.61 KB, application/x-font-ttf)
2015-09-17 19:09 UTC, Roman Kuznetsov
Details
Second screenshot with not correct symbols (16.39 KB, image/png)
2015-09-17 19:11 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2015-09-17 19:08:01 UTC
Created attachment 118802 [details]
LO Math Element bar with not correctly special symbol

Версия: 5.1.0.0.alpha1+
ID сборки: 88c51cd55d1a9b29e62269c53b3923770253ab07-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-09-11_13:09:15
Локаль: ru-RU (ru_RU)

In Math on Element panel special symbols do not display correctly (see screenshot). For normal display to install a third-party font OpenSymbol.

Font from LO distributiv - 201 448 byte
Font from third-party - 203 372 byte
Comment 1 Roman Kuznetsov 2015-09-17 19:08:49 UTC
Created attachment 118803 [details]
Font from LO install
Comment 2 Roman Kuznetsov 2015-09-17 19:09:35 UTC
Created attachment 118804 [details]
Font from third-party
Comment 3 Roman Kuznetsov 2015-09-17 19:11:35 UTC
Created attachment 118805 [details]
Second screenshot with not correct symbols
Comment 4 tommy27 2015-09-19 05:54:17 UTC
is this someway related to Bug 76239 ?
Comment 5 Roman Kuznetsov 2015-09-19 12:51:49 UTC
(In reply to tommy27 from comment #4)
> is this someway related to Bug 76239 ?

yes, that error similar to my. IMHO, the solution is to replace the font file in the distribution LO to normal
Comment 6 tommy27 2015-09-19 13:44:38 UTC
could we close this as a duplicate or you think it's a related but different issue?
Comment 7 Adolfo Jayme 2015-09-19 16:19:12 UTC
Hm, what’s the point of this duplicate report? And why are you recommending to install a third-party version?
Comment 8 Roman Kuznetsov 2015-09-19 16:26:35 UTC
(In reply to Adolfo Jayme from comment #7)
> Hm, what’s the point of this duplicate report? And why are you recommending
> to install a third-party version?

because it solves the problem!
Comment 9 Roman Kuznetsov 2015-09-19 16:32:21 UTC
(In reply to tommy27 from comment #6)
> could we close this as a duplicate or you think it's a related but different
> issue?

wait please
Comment 10 Adolfo Jayme 2015-10-02 10:38:53 UTC
I still don’t understand what’s different about this bug report, and why are you picking up a non-official version of OpenSymbol.
Comment 11 tagezi 2015-10-02 11:35:49 UTC
(In reply to Adolfo Jayme from comment #10)
> I still don’t understand what’s different about this bug report, and why are
> you picking up a non-official version of OpenSymbol.

kompilainenn says that this bug observed with using the official OpenSymbol font from LO at least in Windows 7 and newer with Russian localization. From solution this problem usually is used the font from Ubuntu or downloaded from somewhere to Internet.

In Russian community is famous problem, for example: 
http://forumooo.ru/index.php/topic,4743.0.html
http://forumooo.ru/index.php/topic,4548.msg28953.html#msg28953
Comment 12 Maxim Monastirsky 2015-10-03 18:47:17 UTC
(In reply to Lera from comment #11)
> kompilainenn says that this bug observed with using the official OpenSymbol
> font from LO at least in Windows 7 and newer with Russian localization.
OK, but you still have to explain, why do you think it's a different bug than Bug 76239.

> solution this problem usually is used the font from Ubuntu or downloaded
> from somewhere to Internet.
Downloading from "somewhere" is never a good idea. If anything, try the official git repo under extras/source/truetype/symbol. You have there the ttf file as well as the sfd source to build yourself using FontForge. You can browse the history of the file there, and pick whatever version you want:

http://cgit.freedesktop.org/libreoffice/core/tree/extras/source/truetype/symbol
 
> In Russian community is famous problem, for example: 
> http://forumooo.ru/index.php/topic,4743.0.html
> http://forumooo.ru/index.php/topic,4548.msg28953.html#msg28953
Sorry to say, but this has nothing to do with kompilainenn's report. These forum threads are about LO releases, while kompilainen's report is only about master (otherwise it must be a dup of Bug 76239). kompilainenn claims that the version of 201 448 bytes doesn't work, but the one with 203 372 bytes works. Now, the one with 203 372 bytes *is the one* that was shipped with LO releases up to 5.0.2.
Comment 13 Roman Kuznetsov 2015-10-03 19:36:34 UTC
(In reply to Maxim Monastirsky from comment #12)
> (In reply to Lera from comment #11)
> > kompilainenn says that this bug observed with using the official OpenSymbol
> > font from LO at least in Windows 7 and newer with Russian localization.
> OK, but you still have to explain, why do you think it's a different bug
> than Bug 76239.
> 
> > solution this problem usually is used the font from Ubuntu or downloaded
> > from somewhere to Internet.
> Downloading from "somewhere" is never a good idea. If anything, try the
> official git repo under extras/source/truetype/symbol. You have there the
> ttf file as well as the sfd source to build yourself using FontForge. You
> can browse the history of the file there, and pick whatever version you want:
> 
> http://cgit.freedesktop.org/libreoffice/core/tree/extras/source/truetype/
> symbol

I did not understand what information is required of me
Comment 14 Maxim Monastirsky 2015-10-03 20:32:10 UTC
Hi kompilainenn,

(In reply to kompilainenn from comment #13)
> I did not understand what information is required of me
Well, it would be good to know:

1) Why do you think it isn't the same as Bug 76239? (In comment 9 you wrote "wait please", but never came with a follow-up clarification on this).

2) When you say that the 201 448 bytes font doesn't work, did you try to remove it from your system, and manually re-install the *same* one? Does it work then?
Comment 15 Roman Kuznetsov 2015-10-03 22:05:34 UTC
(In reply to Maxim Monastirsky from comment #14)
> Hi kompilainenn,
> 
> (In reply to kompilainenn from comment #13)
> > I did not understand what information is required of me
> Well, it would be good to know:
> 
> 1) Why do you think it isn't the same as Bug 76239? (In comment 9 you wrote
> "wait please", but never came with a follow-up clarification on this).
> 

I do not think so

> 2) When you say that the 201 448 bytes font doesn't work, did you try to
> remove it from your system, and manually re-install the *same* one? Does it
> work then?

I removed the font size to 201,448 bytes from the specified directory /windows/fonts - startup Math -  special characters are displayed incorrectly
I picked up the font size to 201,448 bytes of delivery LO 5.1 and set it to the system directory - problem has been resolved

Maxim, maybe I was wrong, yes
Comment 16 Maxim Monastirsky 2015-10-03 22:21:28 UTC
Thanks for confirming, so let's mark it as a duplicate.

*** This bug has been marked as a duplicate of bug 76239 ***