Bug 94350 - Crash when applying gradient background to chart
Summary: Crash when applying gradient background to chart
Status: RESOLVED DUPLICATE of bug 93978
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-09-19 02:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-10-01 18:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample (12.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-19 02:37 UTC, Yousuf Philips (jay) (retired)
Details
backtrace (31.72 KB, text/plain)
2015-09-20 06:08 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-19 02:37:39 UTC
Created attachment 118839 [details]
sample

Steps:
1) Open attached file
2) Enter chart edit mode
3) Format the data series by setting area to none and set border style to continuous
4) Format chart area and change area fill from color to gradient
5) Crash

Regression as this doesnt happen in 4.4 daily. Possible vclptr? Seems very similar to bug 92074 and bug 92213.

Version: 5.0.3.0.0+
Build ID: 4ae70fd6c93087ce66c76d3102ad678bcf01dbf5
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-09-18_11:42:55
Locale: en-US (en_US.UTF-8)
Comment 1 Julien Nabet 2015-09-19 05:47:47 UTC
Just for the record, on pc Debian x86-64 with master sources updated yesterday, I don't reproduce this.
Comment 2 m.a.riosv 2015-09-20 00:16:54 UTC
I can't reproduce with:
Win10x64
Version: 5.0.2.2 (x64) Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Version: 5.0.3.0.0+ Build ID: 4ae70fd6c93087ce66c76d3102ad678bcf01dbf5-GL
  TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-0, Time: 2015-09-18_12:03:30
Version: 5.1.0.0.alpha1+ Build ID: ac226443522c55ab75cab8eed354b999052135a7
  TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-09-18_23:26:58

If with a clean reset it happens, then try if some option in
 Menu/Tools/Options/LibreOffice/View - Graphics output
has any effect on it.
Comment 3 Yousuf Philips (jay) (retired) 2015-09-20 06:08:52 UTC
Created attachment 118867 [details]
backtrace

Version: 5.1.0.0.alpha1+
Build ID: 2dea4d270806f47a324cb09c1db7751499930cf7
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2015-09-19_04:51:40
Locale: en-US (en_US.UTF-8)
Comment 4 Maxim Monastirsky 2015-09-20 06:43:45 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> Created attachment 118867 [details]
> backtrace
Another one to the collection of Bug 93978 and related bugs.
Comment 5 Buovjaga 2015-09-20 16:38:05 UTC
No repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 6 Yousuf Philips (jay) (retired) 2015-09-20 23:20:25 UTC
Was also able to reproduce this with the following steps:
1) Open Writer
2) Insert Chart
3) Enable 3d look in chart type dialog
4) Select various data types and then the legend
5) Change chart area fill to gradient
6) Undo if it hasnt crashed
7) Repeat steps 4 to 6 until it crashes, which normally happens on the 3rd attempt for me, but sometimes it takes longer
Comment 7 Buovjaga 2015-09-21 05:47:51 UTC
(In reply to Yousuf (Jay) Philips from comment #6)
> Was also able to reproduce this with the following steps:
> 1) Open Writer
> 2) Insert Chart
> 3) Enable 3d look in chart type dialog
> 4) Select various data types and then the legend
> 5) Change chart area fill to gradient
> 6) Undo if it hasnt crashed
> 7) Repeat steps 4 to 6 until it crashes, which normally happens on the 3rd
> attempt for me, but sometimes it takes longer

Tried this ~8 times, but no crash.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 8 Maxim Monastirsky 2015-10-01 18:31:35 UTC

*** This bug has been marked as a duplicate of bug 93978 ***