Download it now!
Bug 94420 - Selection of adjacent columns has changed to Excel variant, very laborious.
Summary: Selection of adjacent columns has changed to Excel variant, very laborious.
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Selection
  Show dependency treegraph
 
Reported: 2015-09-21 19:40 UTC by Bob
Modified: 2018-06-06 10:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob 2015-09-21 19:40:04 UTC
A very useful feature of Open Office(still functioning in OOO) and the early Libra office was in selecting data in a column that had null values you could cheat by selecting a column in a set of columns that was fully populated, then using the shift key have the column with nulls fully selected. 

Example: Column A is fully populated for 25 rows. Column B is sparsely populated with a whole lot of nulls. I would like to select the values in column B for every row represented in Column A: 

OOO method 

1.Place cursor in Column B1. 
2. SHIFT & CTRL  and left arrow 
3. SHIFT & CTRL and Down arrow
4. SHIFT and Right arrow 

Column B is now selected for the populated area of A. Very quick and easy. It also works for non adjacent column's. Fantastic feature that is not in Xcel or now Libre Office. I often switch to OOO just to use this feature if I have large spreadsheets to select data in. 

Libre Office/Excel method. 

The only Workaround I have discovered here is to place a value in B26 and use SHIFT and Down Arrow, bouncing to each non null cell until I have selected all of B. 
Laborious. 

Have  Fun 

Bob
Comment 1 Buovjaga 2015-09-22 13:35:29 UTC
SHIFT and Right arrow removes column A from the selection. This is true also in LibreOffice 3.5.0.

I guess I'll set to NEW.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2016-11-08 10:29:37 UTC Comment hidden (obsolete)
Comment 3 Gilward Kukel 2017-01-12 04:15:16 UTC
still present in
Version: 5.2.4.2
Build-ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
Windows 7

I also used to do it like that.

Better workaround:
1.Place cursor in Column B1. 
2. SHIFT & CTRL  and left arrow 
3. TAB
4. SHIFT & CTRL and Down arrow
5. TAB
6. SHIFT and Right arrow
Comment 4 Gilward Kukel 2017-01-12 04:24:20 UTC
> Better workaround:
> 1.Place cursor in Column B1. 
> 2. SHIFT & CTRL  and left arrow 
> 3. TAB
> 4. SHIFT & CTRL and Down arrow
> 5. TAB
> 6. SHIFT and Right arrow

Let me change that to:
> 1.Place cursor in Column B1. 
> 2. SHIFT & CTRL  and left arrow 
> 3. TAB
> 4. SHIFT & CTRL and Down arrow
> 5. SHIFT+TAB (less work than TAB when the columns are not adjacent)
> 6. SHIFT and Right arrow
Comment 5 QA Administrators 2018-01-13 03:30:20 UTC Comment hidden (obsolete)
Comment 6 Bob 2018-01-13 12:50:02 UTC
Hi 
You guys sent out a request as to if this bug is present in Libra 6. Yes it is but its probably not a bug as such. 

Having now worked with Libra office and all its respective iterations up to 6 and same with excel and its iterations to 2017, Buovjaga is probably correct this a feature and not a bug. (still use OOO for some functions) 

This feature is very useful when having to populate large spread sheets with many rows and columns with repetitive formula.

Microsoft has made their column select and copy function, even less functional. with now the shift up arrow combination  taking you to page top and not to column top, and if a table is involved things get very quickly in a mess,  which, if the user is not aware of this strange behavior can lead to sections of spreadsheets being populated with different formula. (perhaps this why they needed to introduce that irritating error detection zombie. ( shows if formulae in columns are not consistent,) 

The Workarounds listed, yes all work, but there underlying premise is wrong, multiple TAB's or multiple down arrow.

 They are using the primary column ( selected cell in this column) to select the next populated row. The OOO function uses the final column (left or right) once shift is pressed to determine last populated row of that column and therefore its simply a three key entry. 

The question that arises of course, do you want to match Excel behavior or OOO behavior. This not a question I can answer, as it is a strategic question. I certainly hope you never emulate the copy and paste behavior of Excel, where it clears the clipboard as soon as a new command is issued or has no way of recognizing the difference between insert clipboard or insert anything else.

Thanks for taking the time to ask the question, was getting frustrated with some of your administrators dismissive remarks to users that have brought things up on the forums, hopefully there is light at the end of the tunnel. Will start sending in more bugs as at least I think they will be heard and not simply dismissed.

Have a beautiful day
Bob
Comment 7 Buovjaga 2018-01-13 13:31:21 UTC
(In reply to Bob from comment #6)
> The question that arises of course, do you want to match Excel behavior or
> OOO behavior. This not a question I can answer, as it is a strategic
> question. I certainly hope you never emulate the copy and paste behavior of
> Excel, where it clears the clipboard as soon as a new command is issued or
> has no way of recognizing the difference between insert clipboard or insert
> anything else.

Right, we should get design team involved.
Comment 8 Heiko Tietze 2018-01-14 10:18:27 UTC
Let's better ask Eike. There should be a reason why the selection method has been removed. Probably because most users don't want to _match columns_ always with the method but _select a range_ defined in another column. How was that possible back in the old days?

Btw, it's not clear to me if "null" means 0 or empty cells.
Comment 9 Regina Henschel 2018-06-05 18:34:18 UTC
1. Set Cursor in data in column A.
2. Use Ctrl+ArrowDown to move cursor to last data in column A.
3. Use ArrowRight to move cursor to column B.
Notice, no selection up to now.
4. Use Shift+'Click on first data in column B'. In case you want a marked area starting in row 1, then Shift+PgUp will work too.
Comment 10 Cor Nouws 2018-06-05 21:46:10 UTC
Hi Bob,

Please use
   Tools > Option > Calc > General ... "Use legacy cursor movement behavior when selecting"

See also bug 113235

Cor
Comment 11 Bob 2018-06-05 22:37:54 UTC
You are a star! 

Just tried it and it works. Fantastic

Have a beautiful day
Bob