Bug Hunting Session
Bug 94444 - Writer randomly hides document text (fails to repaint parts of window)
Summary: Writer randomly hides document text (fails to repaint parts of window)
Status: RESOLVED DUPLICATE of bug 92305
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-22 12:39 UTC by Pierre Fortin
Modified: 2015-09-30 15:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (297.31 KB, image/jpeg)
2015-09-22 12:39 UTC, Pierre Fortin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Fortin 2015-09-22 12:39:20 UTC
Created attachment 118929 [details]
screen shot

This bug is easy to reproduce when the document pages are displayed thus:
1 2
3 4
...

Scrolling the display randomly fails to display(draw) screen parts.  The cursor can be moved into the hidden section and text can be typed which will display.

This is a partial screen shot of LibreOffice
    Version: 5.0.0.5
    Build ID: 437e4abdf9e72fd0a6e6f8697a0e659bc77f9b10
    Locale: en-US (en_US.UTF-8)

In this case, part of a page is missing.  The bug is easier to reproduce when LO displays 2 pages wide and scrolling.  Once triggered, I was able to move the cursor into the hidden area and start typing as seen in this screen shot.
Scrolling the newly typed line offscreen and back results in it being hidden again; until I type any character. The line partially reappears with the last two words, and the beginning of the line reappears on its own a second or two later.

Tried scrolling missing area offscreen and back; but this time pressed Backspace -- now, newly typed text does not display.  Typing anything moves the cursor; but nothing displays (red-highlighted area in screen shot) -- only the gray background and cursor are visible.

System: Dell Precision M6800 i7-4710MQ CPU @ 2.50GHz 32GB RAM 
Video:  [laptop] Saturn XT [FirePro M6100] (AMD/ATI)
                 Card:ATI Radeon HD 6400 and later (radeon/fglrx)
        [2nd] 4th Gen Core Processor Integrated Graphics Controller (Intel)
                 Intel 810 and later
Display: 1920x1080
Comment 1 tommy27 2015-09-22 14:16:21 UTC
did you retest with 5.0.1 or 5.0.2 versions?
Comment 2 Buovjaga 2015-09-22 14:57:03 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 Pierre Fortin 2015-09-22 15:02:05 UTC
No; but 5.0.3 seems to be OK...  will keep testing...
Comment 4 Maxim Monastirsky 2015-09-30 15:02:14 UTC

*** This bug has been marked as a duplicate of bug 92305 ***