Bug 94449 - Changing the paragraph style removes index entries.
Summary: Changing the paragraph style removes index entries.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: All All
: medium minor
Assignee: Oliver Specht (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.3 target:5.0....
Keywords: bibisected, regression
: 97734 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-22 18:22 UTC by Jon
Modified: 2016-10-25 19:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon 2015-09-22 18:22:52 UTC
Bug found in 5.0.1 in Windows, found not to exist in 4.3.3 in Linux

To reproduce:

-Open new document
-Insert > Indexes and Tables > Indexes and Tables
-Change "Type" to "Alphabetical Index"
-OK. A index listing is inserted.

-Some lines below, type a word.
-Select the word, Insert > Indexes and Tables > Entry ...
-click "Insert"
-click "Close"
-Right click on the previously made index listing > "update Index / table"
All is as it should be. The word shows up in the index listing with the page number.

The problem:
-Click on the word in the text body
-Change the paragraph style in the toolbar.
-Right click on the previously made index listing > "update Index / table"

The index entry has been removed.
Comment 1 Buovjaga 2015-09-27 14:50:39 UTC
Reproduced.

It is not in 4.3.0.1 Windows either, so I guess it exists in current Linux, too and can be bibisected.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 2 raal 2015-10-01 11:09:41 UTC
Works OK in oldest, latest range in bibisect-win32-5.0, latest:Version: 5.0.0.0.alpha1+
Build ID: ab465b90f6c6da5595393a0ba73f33a1e71a2b65
Comment 3 raal 2015-10-14 09:05:58 UTC
I can not reproduce in Version: 5.1.0.0.alpha1+
Build ID: 233b9b0ec95069b5ce98aab942304459ca7344a8

Please could you retest with current dev version? http://dev-builds.libreoffice.org/daily/master/
Thanks
Comment 4 Robinson Tryon (qubit) 2015-12-14 05:32:32 UTC Comment hidden (obsolete)
Comment 5 Joel Madero 2015-12-19 23:58:33 UTC
Bodhi Moksha

Minor - can slow down professional quality work but will not prevent it;
Medium - default is low for minor bugs but this is a regression

591ce8a7ae0d77f6dd519cecd5d4dfaf94d19559 is the first bad commit
commit 591ce8a7ae0d77f6dd519cecd5d4dfaf94d19559
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 23:06:43 2015 +0800

    source-hash-3c0805e1f4f4d14e92c7e655d59c87de5c207e48
    
    commit 3c0805e1f4f4d14e92c7e655d59c87de5c207e48
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Thu May 14 11:34:33 2015 +0200
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Thu May 14 11:39:16 2015 +0200
    
        tdf#86639 SwEditShell: when setting para style, reset char attrs if needed
    
        The old internal RTF filter used to call SwTxtNode::SetAttr() without
        setting SetAttrMode::NOFORMATATTR, so character attributes which cover
        the whole node got converted to paragraph attributes.  The new UNO
        filter goes through SwXText::insertTextPortion(), which sets
        SetAttrMode::NOFORMATATTR, so this doesn't happen. The result of this is
        that when the UI sets a new paragraph style on the text node, then such
        character attributes are no longer removed.
    
        Given that in RTF you can't really have character properties on a
        paragraph, going back to the document model produced by the old internal
        filter doesn't sound like the good direction -- not to mention that
        changing SwXText::insertTextPortion() this way would be an implicit API
        change.
    
        Fix the problem by tweaking SwEditShell::SetTxtFmtColl() instead, so
        that it removes these full-text-node character attributes, too. The
        logic in SwTxtNode::RstTxtAttr() can be extended later if necessary to
        delete more attributes, but to be on the safe side, just handle the bare
        minimum necessary to fix the problem for now.
    
        Change-Id: I5faa3226fc0f9c18e005da185fe0830d8c393256

:040000 040000 9d5492d125b74a5ad96abd204bbea87a91f7a034 d513106f5f5fdb80fb364ad62a7cc61afaa088ba M	opt


# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# good: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect good 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# good: [40875247f0002056effdf6d2fbe43627691cd86c] source-hash-93f0b14458a618ad575cd446680e5c4aa7d87bdc
git bisect good 40875247f0002056effdf6d2fbe43627691cd86c
# skip: [61f66b1a251477193d796411ca95f50d606ead45] source-hash-3fd5f8919ec2256c70ff26c14cb9f8065c5cb2f1
git bisect skip 61f66b1a251477193d796411ca95f50d606ead45
# skip: [e7374cd735af2344dae55be40946d96633d2f6ee] source-hash-8a91528a3e03fe6e2923c33327b687ecf57adb0b
git bisect skip e7374cd735af2344dae55be40946d96633d2f6ee
# good: [c46e8711268a7866a2886e1297c6cd0438381489] source-hash-82d68f9cbce4073a727c43b4a8e81d39871b71eb
git bisect good c46e8711268a7866a2886e1297c6cd0438381489
# bad: [c53ee7d56c268f9770885fee6121ca921c4314ab] source-hash-4ee3eabd0f058b26544c84b2b5aaf5478d921817
git bisect bad c53ee7d56c268f9770885fee6121ca921c4314ab
# good: [6571735c983a5b071fdd084923d0f10ba90b9a03] source-hash-47ac1b7445520c04f4c98bac925fe14257fd8098
git bisect good 6571735c983a5b071fdd084923d0f10ba90b9a03
# bad: [591ce8a7ae0d77f6dd519cecd5d4dfaf94d19559] source-hash-3c0805e1f4f4d14e92c7e655d59c87de5c207e48
git bisect bad 591ce8a7ae0d77f6dd519cecd5d4dfaf94d19559
# good: [68238466599f5fbc541e999636b21d7667241566] source-hash-1a83ac554873af3ecd0e0b9ab4917e600ee863aa
git bisect good 68238466599f5fbc541e999636b21d7667241566
# good: [9917a0d0384f3873a79bd2e11c8c647e78d17425] source-hash-83120950d5138577185598f5eaf8a267d2244dd1
git bisect good 9917a0d0384f3873a79bd2e11c8c647e78d17425
# good: [751add00069f0a8c99bc766f06556d6d36876641] source-hash-5dfae3f6e39f6a39e04754fe8abb3f711581f75e
git bisect good 751add00069f0a8c99bc766f06556d6d36876641
# good: [d4bf8f60f14cf31cd3dcffe766fc672840feaf52] source-hash-4653c91a89cfe802754377bcdafc291526254a03
git bisect good d4bf8f60f14cf31cd3dcffe766fc672840feaf52
# good: [d967db60860561355370f32f47655ad827252ca8] source-hash-1231d6f3aef712ca7f72908db6f00a498768de47
git bisect good d967db60860561355370f32f47655ad827252ca8
# good: [73d51ba4e004f7694a66c950590663408cdaff9d] source-hash-7e9a4944e53d95f7defb1da384b665e65b2ebc55
git bisect good 73d51ba4e004f7694a66c950590663408cdaff9d
# first bad commit: [591ce8a7ae0d77f6dd519cecd5d4dfaf94d19559] source-hash-3c0805e1f4f4d14e92c7e655d59c87de5c207e48
Comment 6 Joel Madero 2015-12-20 00:00:37 UTC
vmiklos - I believe this may be related to 	3c0805e1f4f4d14e92c7e655d59c87de5c207e48

Please forgive me if I'm wrong. Tried testing but conflicts prevented me from reverting the patch.
Comment 7 Commit Notification 2016-03-29 11:42:39 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07aa86973f4c312eac92e0d4b32b607f5f991ddb

tdf#94449: special text attributes are not removed with paragraph style

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Stahl (CIB) 2016-04-14 12:42:57 UTC
Oliver fixed it
Comment 9 Commit Notification 2016-04-14 13:58:46 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af103f2c0425777afcb616bd1a2c582cfd256b25&h=libreoffice-5-1

tdf#94449: special text attributes are not removed with paragraph style

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-04-26 09:53:38 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba86e97a55e2d6f8716681fb626a8dc3d691aa84&h=libreoffice-5-0

tdf#94449: special text attributes are not removed with paragraph style

It will be available in 5.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-04-26 18:58:54 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7cb9bf3b9bd858c0dcaff49894b84d667abc65cf&h=libreoffice-5-0-6

tdf#94449: special text attributes are not removed with paragraph style

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Stahl (CIB) 2016-05-09 13:03:30 UTC
*** Bug 97734 has been marked as a duplicate of this bug. ***