Bug Hunting Session
Bug 94489 - Predefined Templates are not Editable
Summary: Predefined Templates are not Editable
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2015-09-24 13:46 UTC by Harald Koester
Modified: 2017-04-29 13:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-09-24 13:46:02 UTC
Users may like to customize the predefined templates e.g. in order to insert their address or to translate the template into their own language. This is not possible. It's only possible to create an additional template.

In order to reproduce the bug:
[1] Start LibreOffice and open template Manager: File > New > Templates
[2] Select: Tab Documents > folder Business Correspondence > “Moderate” business letter
[3] Click Edit. The document is opened in read-only mode.
[4] Click Edit Document. The message, that the document cannot be edited, possibly due to missing access rights, is displayed and you are asked if you want to edit a copy of the document. Expected: Template should be editable.

Proposal in order to fix this bug: If a user profile does not exist and LibreOffice is started the first time, the predefined templates should be copied into the new user profile. Hence the user has the right to modify files in his profile, it should be possible to edit templates.
Comment 1 Buovjaga 2015-09-28 08:46:40 UTC
No problem here.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 2 Harald Koester 2015-09-28 13:16:48 UTC
Hi Beluga,

you are right if you are a user with admin rigths. In this case you modify the template for all(!?) users of your system. On my system, if I work as a user with no admin rights the behaviour is as described in my first description.

Cheers
Comment 3 Regina Henschel 2016-03-20 16:33:57 UTC
I think, the current behavior is correct. If the file is in the installation directory, a user with restricted rights should not be allowed to edit the file. You can get your personal copy on demand, so I see no problem here.
Comment 4 Cor Nouws 2016-06-07 11:49:33 UTC
(In reply to Regina Henschel from comment #3)
> I think, the current behavior is correct. If the file is in the installation
> directory, a user with restricted rights should not be allowed to edit the
> file. You can get your personal copy on demand, so I see no problem here.

Yes, I agree with that.