Bug Hunting Session
Bug 94511 - LibO doesn't start with Gnome 3.18 and Numix theme
Summary: LibO doesn't start with Gnome 3.18 and Numix theme
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 94916 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-25 18:37 UTC by bgblanch
Modified: 2015-11-21 11:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (1.23 KB, application/gzip)
2015-10-12 15:29 UTC, soren121
Details
backtrace (1.82 KB, text/x-log)
2015-10-13 09:48 UTC, Nick Sarten
Details
Backtrace (1.77 KB, application/gzip)
2015-10-14 04:46 UTC, Nick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bgblanch 2015-09-25 18:37:56 UTC
I am receiving the following error when trying to start any of the Libreoffice applications with Gnome 3.18 on Antergos:

(soffice:10698): GLib-GObject-CRITICAL **: g_value_set_boxed: assertion 'G_VALUE_HOLDS_BOXED (value)' failed

(soffice:10698): GLib-GObject-WARNING **: gtype.c:4268: type id '0' is invalid

(soffice:10698): GLib-GObject-WARNING **: can't peek value table for type '<invalid>' which is not currently referenced


Linux Antergos-Carbon 4.1.6-1-ARCH #1 SMP PREEMPT Mon Aug 17 08:52:28 CEST 2015 x86_64 GNU/Linux
Comment 1 tommy27 2015-09-30 05:34:41 UTC
LibO 5.0.2 is out. 
please upgrade and tell if issue persists.
Comment 2 Buovjaga 2015-10-02 08:30:15 UTC
Installed Gnome 3.18 on my Antergos 64-bit (by enabling testing repo). No problem launching LibO 5.0.1 apps.
Comment 3 tommy27 2015-10-02 09:15:33 UTC
@bgblanch
please retest with 5.0.2 and give feedback

NEEDINFO until then
Comment 4 Chris De Cairos 2015-10-09 02:09:24 UTC
I'm also unable to start Libreoffice with the same errors as the reporter.

I'm running gnome 3.18 on Antergos as well.

$ libreoffice --version
LibreOffice 5.0.2.2 00m0(Build:2)
Comment 5 Gökçen Eraslan 2015-10-09 09:08:21 UTC
Reproducible with Gnome 3.18 and Libreoffice 5.0.2.2 here.
Comment 6 Gökçen Eraslan 2015-10-09 09:12:03 UTC
Hmm, it seems it's specific to Antergos (i.e. Numix GTK theme). Changing the GTK theme solves the problem.
Comment 7 Chris De Cairos 2015-10-09 15:00:33 UTC
Yup, changing from Numix-Frost to Arc seems to stop the crash. Wouldn't call that a fix though :)
Comment 8 Buovjaga 2015-10-09 16:34:29 UTC
*** Bug 94916 has been marked as a duplicate of this bug. ***
Comment 9 Gökçen Eraslan 2015-10-10 11:27:43 UTC
Changing the theme to Adwaita leads to a different problem. LibreOffice does start in this case, but while using Calc, when I try to click on the "save as" button, it crashes. It should be something related to again GTK theme and GTK VCL plugin where the Save dialog triggers the crash.

Defining SAL_USE_VCLPLUGIN=gen provides a workaround for this problem.
Comment 10 Buovjaga 2015-10-10 11:55:26 UTC
(In reply to Gökçen Eraslan from comment #9)
> Changing the theme to Adwaita leads to a different problem. LibreOffice does
> start in this case, but while using Calc, when I try to click on the "save
> as" button, it crashes. It should be something related to again GTK theme
> and GTK VCL plugin where the Save dialog triggers the crash.

Perhaps you could try getting a backtrace of the crash and then creating a new report for it and linking to it here by saying "bug xxxxxx".
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 11 Buovjaga 2015-10-10 17:50:28 UTC
(In reply to Gökçen Eraslan from comment #9)
> Changing the theme to Adwaita leads to a different problem. LibreOffice does
> start in this case, but while using Calc, when I try to click on the "save
> as" button, it crashes. It should be something related to again GTK theme
> and GTK VCL plugin where the Save dialog triggers the crash.
> 
> Defining SAL_USE_VCLPLUGIN=gen provides a workaround for this problem.

It seems the crash is reported as bug 94936, can you confirm there (same messages in terminal etc.)?
Comment 12 soren121 2015-10-12 15:29:24 UTC
Created attachment 119538 [details]
Backtrace
Comment 13 soren121 2015-10-12 15:30:19 UTC
94936 doesn't seem to be identical. I can't get LibreOffice to even start with the GTK2 VCL.

I attached a backtrace of my own.
Comment 14 Nick Sarten 2015-10-13 09:48:29 UTC
Created attachment 119551 [details]
backtrace

I was just about to create another bug for this. Libreoffice started crashing at startup on my x86_64 Antergos Linux machine after the most recent update.

LibreOffice 5.0.2.2 00m0(Build:2)

Attached a backtrace. Switching my theme from Numix-Frost did fix the crash for me, but I'd rather keep my theme as is.
Comment 15 bgblanch 2015-10-13 14:46:52 UTC
I am also now unable to open evolution.  I'm getting the same error messages.  I was able to use this workaround to get it working for now.

commenting out the few lines containing "link_color" in gtk-3.0/gtk.css and gtk-3.0/gtk-widgets.css of the theme (Numix) seems to "workaround" the issue

https://bbs.archlinux.org/viewtopic.php?id=203512

There appears to be an issue with the Numix stuff.  Unlike some others, changing the theme didn't help for me.  I know that there is also an issue with lightdm and the Numix theme as I'm getting a white screen when trying to log in (separate but related issue is my guess)
Comment 16 soren121 2015-10-14 03:27:31 UTC
The problem would appear to be in GTK+. A fix was released with GTK+ 3.18.2:

https://bugzilla.gnome.org/show_bug.cgi?id=756338

bgblanch, can you upgrade and confirm? 3.18.2 is in the Arch/Antergos repos now.
Comment 17 Nick 2015-10-14 04:46:10 UTC
Created attachment 119591 [details]
Backtrace
Comment 18 Nick 2015-10-14 04:50:33 UTC
Comment on attachment 119591 [details]
Backtrace

The proposed workarounds (editing the libreoffice-fresh.sh) has no effect on this bug and the crash still persists.
Comment 19 soren121 2015-10-14 04:53:37 UTC
(In reply to Nick from comment #18)
> Comment on attachment 119591 [details]
> Backtrace
> 
> The proposed workarounds (editing the libreoffice-fresh.sh) has no effect on
> this bug and the crash still persists.

Which proposed workaround is that? It hasn't been mentioned in this thread.

Have you tried upgrading to 3.18.2? That fixed the issue for me.
Comment 20 Nick 2015-10-14 05:04:59 UTC
(In reply to soren121 from comment #19)
> (In reply to Nick from comment #18)
> > Comment on attachment 119591 [details]
> > Backtrace
> > 
> > The proposed workarounds (editing the libreoffice-fresh.sh) has no effect on
> > this bug and the crash still persists.
> 
> Which proposed workaround is that? It hasn't been mentioned in this thread.
> 
> Have you tried upgrading to 3.18.2? That fixed the issue for me.

Sorry, I was reading a duplicate bug report and confused the two. The duplicate bug author proposed the following solution:

 -Editing /etc/profile.d/libreoffice-fresh.sh and uncommenting either VCLPLUGIN=gtk or gen.

I've tried uncommenting either lines and restarting lboffice with no avail. 

> Have you tried upgrading to 3.18.2? That fixed the issue for me.

I have upgrade my system to 3.18.2 and even with a restart the problem still persists. I am using Antergos/Arch x64 

[nick@Utopia ~]$ uname -a
Linux Utopia 4.2.3-1-ARCH #1 SMP PREEMPT Sat Oct 3 18:52:50 CEST 2015 x86_64 GNU/Linux

[nick@Utopia ~]$ libreoffice --version
LibreOffice 5.0.2.2 00m0(Build:2)

[nick@Utopia ~]$ sudo pacman -Q gtk3
gtk3 3.18.2-1
Comment 21 bgblanch 2015-10-14 05:18:07 UTC
(In reply to soren121 from comment #16)
> The problem would appear to be in GTK+. A fix was released with GTK+ 3.18.2:
> 
> https://bugzilla.gnome.org/show_bug.cgi?id=756338
> 
> bgblanch, can you upgrade and confirm? 3.18.2 is in the Arch/Antergos repos
> now.

@soren121, I'll upgrade GTK+ tomorrow and see if that fixes it.  I just noticed that LibreOffice put out 5.0.3 that is supposed to include a GTK+ fix.  If upgrading GTK+ to 3.18.2 doesn't work, I'll give that a try and update the bug.
Comment 22 Björn Michaelsen 2015-11-21 11:22:34 UTC
(In reply to Nick Sarten from comment #14)
> Created attachment 119551 [details]
> backtrace

(In reply to soren121 from comment #12)
> Created attachment 119538 [details]
> Backtrace

#0  0x00007fffe142f267 in gtk_style_context_get_style_valist ()
   from /usr/lib/libgtk-3.so.0

Both crash in gtk, likely because of data from the themes. Unless this is unmistakeably found to be LibreOffice abusing gtk in some weird way, this is RESOLVED/NOTOURBUG.