Bug 94535 - UI: Cannot open Fontwork dialog to adapt text to connect shape
Summary: UI: Cannot open Fontwork dialog to adapt text to connect shape
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:24.8.0 inReleaseNotes:24.8
Keywords: difficultyMedium, easyHack, skillDesign, topicUI
Depends on:
Blocks: ImpressDraw-Toolbars Connectors FontWork-WordArt
  Show dependency treegraph
 
Reported: 2015-09-26 18:32 UTC by Milan Bouchet-Valat
Modified: 2024-06-04 13:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2015-09-26 18:32:39 UTC
It used to be easy in LO 4.3.4.1 to add text to a connector in Draw, and make it adapt to the shape of the connector using Fontwork. But in LO 4.4.5.2, the button to open the Fontwork dialog is no longer present in the "Drawing" toolbar.

Moreover, there is no longer any reasonable  way of opening that dialog. Indeed, the only workaround I could find to open it is by creating a text frame, right-clicking on it and choosing "Fontwork". Then, if you select the connector text, you can adapt it as previously (and remove the useless text frame when you're done). But this is terribly hard to find, and appears as a feature loss even for experienced users.

Adding a "Fontwork" item to the context menu when a connector text is selected would mitigate the disruption caused by the removal of the Fontwork button from the toolbar. I understand this operation might not be common enough to deserve a permanent button there, but at least it should be accessible without "cheating" by creating different objects.

It would probably also be a good idea to add a "Fontwork dialog" item to the View menu, where it appears logical to look for such a dialog.
Comment 1 Regina Henschel 2015-09-27 21:31:32 UTC
You can customize a toolbar to get quick access to the tool. You find it in category 'format', the command 'Fontwork' with the description 'Edits Fontwork effects of the selected object that has been created with the previous Fontwork dialog'.
Comment 2 Milan Bouchet-Valat 2015-09-27 22:08:22 UTC
(In reply to Regina Henschel from comment #1)
> You can customize a toolbar to get quick access to the tool. You find it in
> category 'format', the command 'Fontwork' with the description 'Edits
> Fontwork effects of the selected object that has been created with the
> previous Fontwork dialog'.

Ah, thanks, indeed this works. So the only change is that this button is now removed by default.

I still think my suggestion to add an item to the context menu makes sense. I know of no other LO feature that can only be accessed by customizing the toolbar... :-)
Comment 3 Regina Henschel 2015-09-27 23:01:09 UTC
(In reply to Milan Bouchet-Valat from comment #2)
> I know of no other LO feature that can only be accessed by customizing the
> toolbar... :-)

The color-depth tools for raster-images too can only be accessed by customizing a toolbar. They are the first items in the category 'Modify'.
Comment 4 Yousuf Philips (jay) (retired) 2015-10-01 12:33:37 UTC
Fontwork was never in the drawing toolbar, so i'm not sure how this could possibly be a regression, but yes, a function should be accessible from atleast 2 places.
Comment 5 Milan Bouchet-Valat 2015-10-01 13:22:27 UTC
Sorry if I was mistaken about it being in the default toolbar. If that's not the case, feel free to remove the regression keyword.

It's not so much about having two ways of accessing a feature, but rather about having one relatively discoverable way (which doesn't involve customizing the toolbars).
Comment 6 Yousuf Philips (jay) (retired) 2015-10-06 11:58:31 UTC
(In reply to Milan Bouchet-Valat from comment #5)
> It's not so much about having two ways of accessing a feature, but rather
> about having one relatively discoverable way (which doesn't involve
> customizing the toolbars).

Unfortunately toolbars can only contain the most used commands in them, and Fontwork is not one, so customizing the toolbar would need to be done to access it from the toolbar. My current thinking is that Fontwork should be added to two places.

1) To the Format menu
2) As a hidden button in the drawing toolbar
Comment 7 Milan Bouchet-Valat 2015-10-06 12:14:05 UTC
Makes sense. Though, if you keep it in the context menu for some object types (like text frames), better add it in other contexts too (like text added to a shape in the present case).
Comment 8 Heiko Tietze 2016-06-21 08:52:21 UTC
It's not consistent to have a button in the toolbar that toggle the fontwork dialog on/off. However, having an entry in the context menu is absolutely necessary, and the main menu would be the alternative access. Both are still missing in 5.3. 
We should also consider to make the font work available in the sidebar, with a limited scope but a simple way to show the dialog.

The dialog itself appears like a floating widget but is a modeless dialog, or rather a non-standard toolbar. As such it is dockable leading to a mess, e.g. it overrides the sidebar. So how about integrating these features into the text dialog? By the way, text properties are overridden by fontwork.

And last but not least I suggest to rename this feature since Fontwork is used for gimmick text (Insert > Media > Fontwork...). Perhaps "alignment" or "adjustment". Wouldn't be a big deal when integrated into "text".
Comment 9 Yousuf Philips (jay) (retired) 2017-05-04 16:29:33 UTC
Not sure how i assigned myself to this, so unassigning it.
Comment 10 Regina Henschel 2018-06-23 21:57:27 UTC
(In reply to Heiko Tietze from comment #8)
> And last but not least I suggest to rename this feature since Fontwork is
> used for gimmick text (Insert > Media > Fontwork...). Perhaps "alignment" or
> "adjustment". Wouldn't be a big deal when integrated into "text".

This "text along path" is a property of the shape, not of the text.

Renaming would be good. And it would be good to have it in the UI in Draw, because you need it to label connectors.
Comment 11 Heiko Tietze 2020-10-29 09:05:52 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #6)
> 1) To the Format menu
> 2) As a hidden button in the drawing toolbar

This proposal make sense.

The command is .uno:Fontwork (not FontworkGalleryFloater), the toolbar ./sd/uiconfig/sdraw/toolbar/toolbar.xml for Draw and /sd/uiconfig/simpress/toolbar/toolbar.xml for Impress. Main menus are /sd/uiconfig/sdraw/menubar/menubar.xml and ./sd/uiconfig/simpress/menubar/menubar.xml

(In reply to Regina Henschel from comment #10)
> This "text along path" is a property of the shape, not of the text.

Let's rename accordingly. UNO command as above, the dialog title is set from the variable RID_SVXSTR_FONTWORK (dialog is dockingfontwork.ui).
Comment 12 Commit Notification 2024-03-01 10:49:55 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/716c1c3c973f2b171efb8eca31498a29364b4548

tdf#94535 Change "Fontwork" to "Text along Path"

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2024-03-01 11:44:20 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ed91fc7214b08112bc73844db3bdaab69f73564

tdf#94535 Improvements in Text along Path dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2024-03-01 23:05:36 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/714426188f79633f1f6e4f180c13aafda4fa4a4b

tdf#94535 Corresponding Help page
Comment 15 Commit Notification 2024-04-22 21:42:59 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/132ed1b713f7379589bd6906036b157301f27209

tdf#94535 Update a Tip of the Day with new command name

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.