Download it now!
Bug 94545 - FILEOPEN: Failed to open UOT file
Summary: FILEOPEN: Failed to open UOT file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: UOF
  Show dependency treegraph
 
Reported: 2015-09-27 08:31 UTC by Tom
Modified: 2017-09-15 15:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2015-09-27 08:31:15 UTC
Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: de-DE (en_US.utf8)
OpenSuse 12.3

When I tried to open an UOT (Unified Office Format text) file that I had created just a minute before with Writer 5.0.2.2, it failed leaving the "busy mouse pointer" on the screen. After terminating LO (fortunately only the mouse pointer symbol was wrong, but the mouse was still fully functional), I found the following messages in the terminal that I had used to start "libreoffice5.0":

runtime error: file file:///opt/libreoffice5.0/program/../share/xslt/import/uof/uof2odf_text.xsl line 2880 element attribute
xsl:attribute: Cannot add attributes to an element if children have been already added to the element.
runtime error: file file:///opt/libreoffice5.0/program/../share/xslt/import/uof/uof2odf_text.xsl line 2854 element attribute
xsl:attribute: Cannot add attributes to an element if children have been already added to the element.
runtime error: file file:///opt/libreoffice5.0/program/../share/xslt/import/uof/uof2odf_text.xsl line 2893 element attribute
xsl:attribute: Cannot add attributes to an element if children have been already added to the element.
runtime error: file file:///opt/libreoffice5.0/program/../share/xslt/import/uof/uof2odf_text.xsl line 2867 element attribute
xsl:attribute: Cannot add attributes to an element if children have been already added to the element.

I am sorry, due to privacy reasons I cannot share the UOT document and the original ODF document. Hopefully, the runtime error gives enough information to narrow down the problem. Since I do not use the UOT format often, I set the severity of this issue to "Minor".

Regards
Tom
Comment 1 Buovjaga 2015-09-28 13:53:24 UTC
You could try this: https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission

I could not repro with my own filesave attempt.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 2 Tom 2015-09-29 07:19:26 UTC
Thanks for the link on how to sanitize files before submission. Unfortunately, the private information I am referring to is not restricted to meta and history data. In fact, the original document is a scientific paper, which includes private and unpublished information in the regular text and figures :-(.

Regards
Tom
Comment 3 Buovjaga 2015-09-29 07:59:09 UTC
(In reply to Tom from comment #2)
> Thanks for the link on how to sanitize files before submission.
> Unfortunately, the private information I am referring to is not restricted
> to meta and history data. In fact, the original document is a scientific
> paper, which includes private and unpublished information in the regular
> text and figures :-(.

Removing figures might be tedious and problematic, if they somehow contribute to the bug.
For text, you can use this https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission#Sanitize_file_text
Comment 4 tommy27 2015-10-03 06:58:45 UTC
I set status to NEEDINFO until a test file is provided
Comment 5 Xisco Faulí 2016-09-11 19:55:21 UTC Comment hidden (obsolete)
Comment 6 Tom 2016-09-25 20:41:18 UTC
Dear QA team,

I am sorry, but I cannot provide an example due to the privacy reasons outlined in my previous comments. I understand, that you have to disqualify an issue, when you are not able to reproduce that issue. Maybe I can reproduce that issue with a less sensitive document sometimes in the future or maybe it has already been addressed unnoticed in one of the recent revisions.

Thanks & Regards
Tom
Comment 7 Buovjaga 2016-09-26 09:12:35 UTC
(In reply to Tom from comment #6)
> or maybe it has already been addressed unnoticed in one of the recent
> revisions.

You can try with the very latest builds: http://dev-builds.libreoffice.org/daily/master/?C=M;O=A
https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 8 Tom 2016-09-26 18:11:18 UTC
Follow-up:

When repeating the same procedure under LO 5.1.5.2 and LO 5.2.1.2 no crash is observed. Instead the error message "General Error. General input/output error." is displayed, which is much better than before. Since the unified office format (uot) is not that important to me, I regard the former issue resolved.

Regards
Tom
Comment 9 Buovjaga 2016-09-26 19:17:12 UTC
Ok, let's set to WFM.
It would still be great to get a testcase, though, so if you some day have time to create a minimal document, do revisit this report.