Bug 94548 - EDITING: Inconsistent field names __RefNumPara__ vs. __RefHeading__
Summary: EDITING: Inconsistent field names __RefNumPara__ vs. __RefHeading__
Status: RESOLVED DUPLICATE of bug 94804
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-27 12:31 UTC by Tom
Modified: 2015-11-04 15:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT document with cross-references to numbered list elements (13.59 KB, application/vnd.oasis.opendocument.text)
2015-09-27 12:31 UTC, Tom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2015-09-27 12:31:24 UTC
Created attachment 119069 [details]
ODT document with cross-references to numbered list elements

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: de-DE (en_US.utf8)

I have an ODT document with more than 100 cross-references to elements of one numbered list that was originally created in LO 4.2 and LO 4.3. When turning on the field names (Ctrl+F9) I noticed that most of these cross-references refer to __RefNumPara__, while some refer to __RefHeading__.

After upgrading to LO 5.0.2.2 (I skipped LO 4.4) all cross-references referring to __RefHeading__ failed. Even after re-inserting all failing cross-references and saving the document, they still refer to __RefHeading__ and they still fail the next time the document is opened and all references are updated per F9.

Unfortunately, I cannot attach the original ODT document for privacy reasons. However, I added a different ODT document that shows that now all references to numbered list elements seem to be inserted as __RefHeading__ field names.

So, my questions are:
1) What is the intended field name for numbered list elements, __RefNumPara__ or __RefHeading__?
2) How can I clean up the >100 cross-references in my ODT document so that they will all work correctly under LO 5.0.2.2?

BTW: I also noted, that „Fields → Cross-references → Insert reference to“ starts always with „Page“, regardless of the setting used for the recently inserted cross-reference. It would be easier for the user, if it would start with the settings used for the recently inserted cross-reference.

Regards
Tom
Comment 1 Michael Stahl (allotropia) 2015-11-04 15:07:03 UTC
yeah that was some horrible bug, fixed in 4.4.6

*** This bug has been marked as a duplicate of bug 94804 ***