Bug Hunting Session
Bug 94573 - invalid encoding in hyph_zu_ZA
Summary: invalid encoding in hyph_zu_ZA
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium trivial
Assignee: Julien Nabet
URL:
Whiteboard: target:5.0.3 target:4.4.6
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-28 13:21 UTC by Mattia Rizzolo
Modified: 2015-09-29 07:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mattia Rizzolo 2015-09-28 13:21:14 UTC
The current zu_ZA hyphenation patterns has the following first line:
    ISO08859-1

I believe the current string is a mispelling for
    ISO8859-1

I'm somewhat unable to find a documentation reference for this, except from looking at the other .dic files.

I fail to find the original source of that dictionary, so I wouldn't know where to report it otherwise.
Wondering if you're ok at diverging for a single byte from the original :)


For cross-reference, this was original reported as a Debian bug, at https://bugs.debian.org/702425
Comment 1 Julien Nabet 2015-09-28 21:13:29 UTC
On pc Debian x86-64 with master sources updated today, I see it's still the case.
Comment 2 Julien Nabet 2015-09-28 21:39:31 UTC
Andras: I pushed a commit about this, see:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=c665002bf194c0cbe180aef3f5c41c1872d4e3cd
But how to cherry-pick and above all submit to gerrit for 5.0 branch?
I'm not accustomed to the other repo (module?subpart?) than core.
Comment 3 Andras Timar 2015-09-29 06:33:28 UTC
Pushed to libreoffice-5-0 and libreoffice-4-4
Comment 4 Julien Nabet 2015-09-29 06:59:58 UTC
Thank you Andras for your quick response! :-)
Comment 5 Mattia Rizzolo 2015-09-29 07:57:01 UTC
Guys you rock!

Getting stuff fixed so quickly is a dream for me :-)