Bug Hunting Session
Bug 94588 - FILEOPEN: ODT - Missing gradients found in <svg:linearGradient> <svg:radialGradient>
Summary: FILEOPEN: ODT - Missing gradients found in <svg:linearGradient> <svg:radialGr...
Status: RESOLVED DUPLICATE of bug 48392
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ODF-import
  Show dependency treegraph
 
Reported: 2015-09-28 23:49 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-13 07:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample doc (9.00 KB, application/vnd.oasis.opendocument.text)
2015-09-28 23:49 UTC, Yousuf Philips (jay) (retired)
Details
calligra pdf export (468.39 KB, application/pdf)
2015-09-28 23:51 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-28 23:49:12 UTC
Created attachment 119105 [details]
sample doc

Steps:
1) Open attached file
2) Notice that all shapes have a black to white linear gradient
3) Compare this with Calligra Words

Version: 5.1.0.0.alpha1+
Build ID: 18c196f0190d9920673cdd9a4dbc158f08959cfd
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-26_00:38:50
Locale: en-US (en_US.UTF-8)

LibreOffice reads and writes gradients in the <draw:gradient> tag, but cant import linear and radial gradients from <svg:linearGradient> and <svg:radialGradient> tags found in styles.xml ( http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#__RefHeading__1416462_253892949 ).

Below are xml examples taken from the attached file.

  <svg:linearGradient draw:name="gradient1" svg:spreadMethod="pad" svg:x1="0.000000%" svg:x2="100.000000%" svg:y1="0.000000%" svg:y2="100.000000%">
   <svg:stop svg:offset="0" svg:stop-color="#ffffff"/><svg:stop svg:offset="1" svg:stop-color="#00ff00"/>
  </svg:linearGradient>

  <svg:radialGradient draw:name="gradient5" svg:cx="50.000000%" svg:cy="50.000000%" svg:fx="25.000000%" svg:fy="25.000000%" svg:r="50.000000%" svg:spreadMethod="pad">
   <svg:stop svg:offset="0" svg:stop-color="#ffffff"/><svg:stop svg:offset="1" svg:stop-color="#00ff00"/>
  </svg:radialGradient>

As <svg:linearGradient> and <svg:radialGradient> tags are capable of having advanced gradients (gradients with more than 2 colors), only the first and last <svg:stop> tags should be read, as LO doesnt have capabilities of handling advanced gradients. LO does the same thing when importing advanced gradients from ooxml files.
Comment 1 Yousuf Philips (jay) (retired) 2015-09-28 23:51:58 UTC
Created attachment 119106 [details]
calligra pdf export
Comment 2 Buovjaga 2015-10-02 08:14:36 UTC
Confirmed

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (fi_FI)
Comment 3 QA Administrators 2017-01-03 19:36:28 UTC Comment hidden (obsolete)
Comment 4 Regina Henschel 2017-09-13 07:24:01 UTC

*** This bug has been marked as a duplicate of bug 48392 ***