Bug 94647 - Page styles don't have a hierarchy
Summary: Page styles don't have a hierarchy
Status: RESOLVED DUPLICATE of bug 41316
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-30 18:48 UTC by Jean-Francois Nifenecker
Modified: 2015-10-01 11:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Nifenecker 2015-09-30 18:48:15 UTC
When heavily working with Writer, one uses styles everywhere. The style functionality is the cornerstone of LibreOffice which makes it really shine and it deserves some care, I'd say.
The Paragraph styles are organized under a hierarchy while Page styles are not. This would be a welcome enhancement that would help very much when writing complex documents where some page styles could inherit from some parents. Thus, a change in a setting (say, margins) would be passed to their heirs without having to set this property to all and any dependant style.
Comment 1 Cor Nouws 2015-09-30 19:35:21 UTC
Should be discussed, I think.
Probably the fact that most styles doe have inheritance but not page styles, is not by incident..?
Comment 2 Jean-Francois Nifenecker 2015-09-30 19:43:45 UTC
(In reply to Cor Nouws from comment #1)
> Should be discussed, I think.
> Probably the fact that most styles doe have inheritance but not page styles,
> is not by incident..?

Hum. *Only* Paragraph style do have inheritance :)

Anyway, the lack of inheritance with page styles is really annoying when having to handle complex documents (reports, thesis, technical documentation or user manuals come to mind). Such documents often have several right page or left page styles. Changing a single parameter in all of these (eg: a margin) becomes tedious because of the lack of an inheritance line.
Comment 3 Cor Nouws 2015-09-30 19:53:34 UTC
(In reply to Jean-Francois Nifenecker from comment #2)
> 
> Hum. *Only* Paragraph style do have inheritance :)

Frames and character styles too :)
> 
> Anyway, the lack of inheritance with page styles is really annoying when
> having to handle complex documents (reports, thesis, technical documentation
> or user manuals come to mind). Such documents often have several right page
> or left page styles. Changing a single parameter in all of these (eg: a
> margin) becomes tedious because of the lack of an inheritance line.

Depends on how often you need to set those margins.

I would really appreciate discussion and good thinking around this. (More than I can offer..)
Comment 4 Jean-Francois Nifenecker 2015-09-30 20:06:11 UTC
(In reply to Cor Nouws from comment #3)
> (In reply to Jean-Francois Nifenecker from comment #2)
> > 
> > Hum. *Only* Paragraph style do have inheritance :)
> 
> Frames and character styles too :)

Gosh. Yep.

> > 
> > Anyway, the lack of inheritance with page styles is really annoying when
> > having to handle complex documents (reports, thesis, technical documentation
> > or user manuals come to mind). Such documents often have several right page
> > or left page styles. Changing a single parameter in all of these (eg: a
> > margin) becomes tedious because of the lack of an inheritance line.
> 
> Depends on how often you need to set those margins.

I chose margins as an example. Of course this applies to all other settings, and there are quite a bunch.

When in conception phase, the changes come quite often and quite extensively until some visual identity is found.
Of course, when the template is done, the changes are less frequent, but when they become necessary (eg changes in the visual identity standards at the customer's) this problem bites again.
Comment 5 Jean-Francois Nifenecker 2015-09-30 20:17:08 UTC
And, of course, inheritance would suppress errors that might occur when duplicating settings from one style to another.
Comment 6 Regina Henschel 2015-10-01 11:32:56 UTC

*** This bug has been marked as a duplicate of bug 41316 ***