Bug Hunting Session
Bug 94672 - OSX 10.11 flags 5.0.2 as corrupt and aborts immediately
Summary: OSX 10.11 flags 5.0.2 as corrupt and aborts immediately
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-01 17:15 UTC by Fred
Modified: 2015-10-03 17:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2015-10-01 17:15:38 UTC
Downloaded file LibreOffice_5.0.2_MacOS_x86-64.dmg directly from site.  DMG file verified as usual before opening, installed, then tried to execute - OSX reports LibreOffice broken and aborts (and erases it from /Application).

I've had this before with LibreOffice_5.0.1_MacOS_x86-64.DMG, but that typically happened if I applied the language pack LibreOffice_5.0.1_MacOS_x86-64_langpack_en-GB.dmg before once opening LibreOffice, so avoided the Langpack completely, to no avail.  Fresh download, tried again, same result.

Reverted to 5.0.1 (D/L via torrent), works fine, langpack applied, still works as expected.

I have not tried the 5.0.2 version that is available in the Apple App Store.

System: OSX 10.11 (El Capitan), 16GB RAM, 2.5 GHz Intel Core i7.
Comment 1 steve -_- 2015-10-01 19:14:32 UTC
hmmm. 10.11 and LO vanilla latest from MAS as well as latest nightly (both as of today 2015-10-01) do run fine here. no language packs.
Comment 2 Fred 2015-10-01 19:42:33 UTC
I am rebuilding this OSX 10.11 MBP from the ground up this weekend, and after that I will try again with a straight download from the LO site, just to be sure.
Comment 3 Alex Thurgood 2015-10-03 14:01:24 UTC
No repro for me either with 

OSX 10.11
Comment 4 Alex Thurgood 2015-10-03 14:02:20 UTC
@Fred : try removing/renaming your LO user profile to see if that makes a difference
Comment 5 Fred 2015-10-03 15:06:36 UTC
OK, the Mac involved has been rebuilt from the ground up, just in case (it needed a cleanup anyway) - problem no longer present.  This was even with a user profile ported from the old system.

Rebuilt under OSX 10.11 with all the trimmings, installed 5.0.1 + en-gb lang pack, no problem.

Downloaded 5.0.2 from libreoffice.org, started OK.  Added en-gb lang pack, no problem starting and adjusting to UK.

Apropos user profile (as per suggestion), I zapped then it so LO could recreate it, also works.  As existing profile was 65M in 1024 files and fresh profile is 1.6MB in 125 files I'll leave the new one as it holds no traces of legacy.

Conclusion: more likely an issue with OSX installation.  Closed bug (if that breaks any protocol, apologies, please amend).
Comment 6 steve -_- 2015-10-03 17:38:37 UTC
Fred thanks a lot for the update. Setting to worksforme since we don't know what fixed things on your end. Might have still been LOs fault. Glad things are now working as expected.