Download it now!
Bug 94725 - Selecting a new object fill setting in Area tab doesnt change other tabs
Summary: Selecting a new object fill setting in Area tab doesnt change other tabs
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Area-Fill-Tab
  Show dependency treegraph
 
Reported: 2015-10-03 09:28 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-11-18 18:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-10-03 09:28:06 UTC
Steps:
1) Open Writer
2) Insert a shape
3) Context Menu > Area
4) Select 'Chart 11'
5) Switch to Colors tab and 'Chart 11' wont be selected
6) Change color to 'Chart 1'
7) Switch to Area tab and 'Tango: Sky Blue 1' will still be selected

This will happen with any of the fill types when jumping between that fill type tab and the Area tab.

Version: 5.1.0.0.alpha1+
Build ID: ef1bafb588eb20a5d35df14e79a1a948885c721a
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-29_23:55:44
Locale: en-US (en_US.UTF-8)
Comment 1 Buovjaga 2015-10-06 11:51:07 UTC
No reproduced.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (fi_FI)
Comment 2 Yousuf Philips (jay) (retired) 2015-10-06 15:49:05 UTC
Still reproducible for me. @Beluga: Which part of the steps didnt work for you?

Version: 5.1.0.0.alpha1+
Build ID: 329496c1f75f97d2e6119ceb214a2ea1fbadb17a
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-03_02:47:24
Locale: en-US (en_US.UTF-8)
Comment 3 Buovjaga 2015-10-06 17:49:36 UTC
1) Open Writer
2) Insert a shape
3) Context Menu > Area
4) Set area color to 'Chart 11'
5) Switch to Colors tab and 'Chart 11' wont be selected - true, Tango: sky blue 1 is selected
6) Change Colors color to 'Chart 1'
7) Switch to Area tab and 'Chart 11' will still be selected

So different result from yours.
Comment 4 Yousuf Philips (jay) (retired) 2015-10-07 06:06:46 UTC
I guess i was mistaken in my instructions about step 7, as it should have been Chart 11. :D
Comment 5 Buovjaga 2015-10-07 06:14:24 UTC
But why should the Area color be tied to what is in the Colors tab? Isn't the purpose of Colors simply to manage colors?
Comment 6 Yousuf Philips (jay) (retired) 2015-10-07 10:03:35 UTC
(In reply to Beluga from comment #5)
> But why should the Area color be tied to what is in the Colors tab? Isn't
> the purpose of Colors simply to manage colors?

Because only colors available in the Colors tab can be selected in the Area tab. The Area tab simply brings all the presets from the Colors, Gradient, Hatching and Bitmap tabs into one place.
Comment 7 Buovjaga 2015-10-07 12:04:53 UTC
(In reply to Yousuf (Jay) Philips from comment #6)
> (In reply to Beluga from comment #5)
> > But why should the Area color be tied to what is in the Colors tab? Isn't
> > the purpose of Colors simply to manage colors?
> 
> Because only colors available in the Colors tab can be selected in the Area
> tab. The Area tab simply brings all the presets from the Colors, Gradient,
> Hatching and Bitmap tabs into one place.

So do I understand you correctly that this is like an enhancement? We would predict that a person switching the Area color and then going to the Colors tab will probably want to manipulate the RGB values of the Area color immediately?
Comment 8 Heiko Tietze 2016-09-12 13:10:12 UTC
This issue is solved with the latest changes as Area is not existing anymore. But as long the patch is not merged we should keep it active.
Comment 9 Xisco Faulí 2017-09-29 08:53:34 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2020-05-31 03:44:52 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2020-11-18 18:12:06 UTC
(In reply to Heiko Tietze from comment #8)
> This issue is solved with the latest changes as Area is not existing
> anymore. But as long the patch is not merged we should keep it active.

We waited for 4 years, so let's close