Bug 94788 - incorrect export footnotes to docx
Summary: incorrect export footnotes to docx
Status: RESOLVED DUPLICATE of bug 55427
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-05 14:25 UTC by Andrew
Modified: 2015-10-09 14:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2015-10-05 14:25:28 UTC
While saving odt document containing footnotes with position "end of the document" to docx format loosing "end of the document" style. All of the footnotes with position "end of the document" became "end of the page" after saving and reopening document.
How to reproduce:
Create docx document with footnotes with position "end of the document", save it. Reopen.
Comment 1 Buovjaga 2015-10-08 08:43:38 UTC
I assume you are speaking about inserting an endnote.
I did not see any problem.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 2 Georgy 2015-10-09 14:04:49 UTC
(In reply to Beluga from comment #1)
> I assume you are speaking about inserting an endnote.
No. By mistake Andrew added footnotes with position "end of the document" (not endnotes). As it set in Tools -> Footnotes/Endnotes. And in odt format it looks good. But if you try to save it as docx and reopen it footnotes will loose "end of the document setting". 
Tried it on Centos 7 64-bit Version Version: 5.0.0.5
> I did not see any problem. 
Have you tried to reproduce ?
> 
> Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
> Build ID: f830600ece806ec365a4839e79afabe183c5e36d
> TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
> Locale: en-US (fi_FI)
Comment 3 Buovjaga 2015-10-09 14:18:25 UTC
(In reply to Georgy from comment #2)
> (In reply to Beluga from comment #1)
> > I assume you are speaking about inserting an endnote.
> No. By mistake Andrew added footnotes with position "end of the document"
> (not endnotes). As it set in Tools -> Footnotes/Endnotes. And in odt format
> it looks good. But if you try to save it as docx and reopen it footnotes
> will loose "end of the document setting". 
> Tried it on Centos 7 64-bit Version Version: 5.0.0.5
> > I did not see any problem. 
> Have you tried to reproduce ?

"I did not see any problem." means that I tried to reproduce it, but there was no problem.

I did not know there is a menu entry Tools -> Footnotes/Endnotes. This is why bug reports should always tell the exact steps to reproduce.

Now I could reproduce.

Yet this is a dupe.

*** This bug has been marked as a duplicate of bug 55427 ***