Download it now!
Bug 94793 - Setting of "Same content on first page" on Template->Footer is overwritten by equivalent setting on Template->Header
Summary: Setting of "Same content on first page" on Template->Footer is overwritten by...
Status: RESOLVED DUPLICATE of bug 100287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2015-10-05 16:50 UTC by Stefan
Modified: 2018-03-05 11:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan 2015-10-05 16:50:00 UTC
1.) Open Modify "Default Style" (Sidebar->Styles & Formatting)
2.) Open Tab "Header" -> set "Header on" & SET "Same content on first page"
3.) Open Tab "Footer" -> set "Header on" & UNSET "Same content on first page"
4.) Click OK to Close
5.) Open the Dialog again and check the values. As you can see, "Same content on first page" at "Footer" is activated again. The setting of "Header" will overwrite these setting on "Footer"

Reproduced on 5.0.2.2
Comment 1 Stefan 2015-10-05 18:30:54 UTC
There was an error in the description (#2):

1.) Open Modify "Default Style" (Sidebar->Styles & Formatting)
2.) Open Tab "Header" -> set "Header on" & SET "Same content on first page"
3.) Open Tab "Footer" -> set "Footer on" & UNSET "Same content on first page"
4.) Click "OK" to Close
5.) Open the Dialog again and check the values. As you can see, "Same content on first page" at "Footer" is activated again. The setting of "Header" will overwrite these setting on "Footer"

Reproduced on 5.0.2.2
Comment 2 Buovjaga 2015-10-08 09:06:03 UTC
Note: this is about the default page style.

Reproduced.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)

4.3.0.1
Comment 3 Cor Nouws 2015-12-02 15:33:51 UTC
This is by design.. So maybe could be changed with an enhancement?
Comment 4 Michael Stahl (CIB) 2018-03-05 11:46:45 UTC
essentially this is a UI bug - the implementation does not allow toggling footer sharing separately from header sharing, because no file format supports that.

also, there is bug 100287 about the same issue.

*** This bug has been marked as a duplicate of bug 100287 ***