Bug Hunting Session
Bug 94871 - [HELP] note and warning paragraphs are aligned incorrectly
Summary: [HELP] note and warning paragraphs are aligned incorrectly
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4 target:4.4.7
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-07 21:49 UTC by tagezi
Modified: 2019-06-29 18:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
example a page (119.76 KB, image/png)
2015-10-07 21:49 UTC, tagezi
Details
.xhp file (8.01 KB, application/xml)
2015-10-08 08:57 UTC, tagezi
Details
screenshot (115.41 KB, image/png)
2015-10-08 11:07 UTC, tagezi
Details
new .xhp file (7.91 KB, application/xml)
2015-10-08 11:08 UTC, tagezi
Details
screenshot with LO5.1 (30.04 KB, image/png)
2015-11-16 22:24 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tagezi 2015-10-07 21:49:08 UTC
Created attachment 119404 [details]
example a page

if you look at the attached screenshot, you see that the paragraph alignment is uneven. In addition, they are placed away from the "note" and "warning" flags that makes it unsightly.

it would be great if between the flags and the paragraph is had a small distance, and all the paragraphs is aligned the left edge.

screenshot made on:
Kubuntu 14.04
LO master at 06.10.2015
Comment 1 Regina Henschel 2015-10-07 23:24:33 UTC
Lera: Please attach the .xhp file too.
Comment 2 tagezi 2015-10-08 08:57:30 UTC
Created attachment 119406 [details]
.xhp file

I attach .xhp file.

Also, you can download the latest version https://gerrit.libreoffice.org/#/c/19236/
Comment 3 Regina Henschel 2015-10-08 10:39:51 UTC
Lera: Your file has a muddle of block-level elements and inline-level elements.

The element 'embed' is a block-level element. It embeds an element 'section'.

Block-level elements are not allowed as child of an element 'paragraph'.

If you want to embed something inside a paragraph, you have to use an inline-level element. So inside a paragraph use an element 'embedvar', which embeds an element 'variable'.

To solve the conflict, do not write

<paragraph id="par_id9397381616478" role="paragraph" localize="false" xml-lang="en-US">
<embed href="text/scalc/01/ex_data_stat_func.xhp#ex_func_average"/>
</paragraph>

but simple write
<embed href="text/scalc/01/ex_data_stat_func.xhp#ex_func_average"/>
Comment 4 Regina Henschel 2015-10-08 10:48:20 UTC
<paragraph id="par_id262061474420658" role="note" xml-lang="en-US"></paragraph>

is needless.
The section, which will be embed with the next element, has got the attribute 'role="note"' itself.
Comment 5 Regina Henschel 2015-10-08 10:51:00 UTC
Delete my last comment.
Comment 6 tagezi 2015-10-08 11:07:36 UTC
Created attachment 119411 [details]
screenshot

Well, I corrected this point, but it has not brought the expected results. 
Paragraphs continue to have uneven alignment. What's next?
Comment 7 tagezi 2015-10-08 11:08:38 UTC
Created attachment 119412 [details]
new .xhp file
Comment 8 Regina Henschel 2015-10-08 11:46:37 UTC
Do the two 'note' paragraphs have the same indent now?

In regard to alignment of 'note'- and 'tip'-paragraph I have no immediate solution. I guess, that it is nothing in the .xhp files, but happens on the way to the help browser. Please switch your icon theme from Tango to Galaxy before viewing the new help page. Is the indent the same then? [The icon size is different in Tango and Galaxy.]
Comment 9 tagezi 2015-10-08 12:26:18 UTC
(In reply to Regina Henschel from comment #8)
> Do the two 'note' paragraphs have the same indent now?
> 
> In regard to alignment of 'note'- and 'tip'-paragraph I have no immediate
> solution. I guess, that it is nothing in the .xhp files, but happens on the
> way to the help browser. Please switch your icon theme from Tango to Galaxy
> before viewing the new help page. Is the indent the same then? [The icon
> size is different in Tango and Galaxy.]

It is Oxygen, I have it default http://itmag.es/5ZUis
It is Tango http://itmag.es/4UPjO
It is Galaxy http://itmag.es/5Oocu

I think that the problem is associated with the table styles
Comment 10 Regina Henschel 2015-10-08 18:08:50 UTC
The problem is surely outside your file. Have a look at the help "Icons in the Documentation" (Search for 'Icons' in 'headings only'). It shows the three types and has the same wrong alignment you have noticed.

AOO uses a constant spacing between icon and text.

LO 4.2 has a constant spacing for 'note' and 'tip' and this large width for 'warning'.

You are right, different table settings result in not aligned paragraphs. But I do not know where these widths are set. I do not find such settings, neither in the .xhp file, nor in the main_transform.xsl nor in the default.css.
Comment 11 Michael Stahl (CIB) 2015-10-28 13:49:23 UTC
this became a lot worse with this commit

commit a219bbb62f974020fac0799143fbc51c385bb460
Author:     Matteo Casalin <matteo.casalin@yahoo.com>
AuthorDate: Mon Sep 1 23:36:14 2014 +0200

    Simplify by early bailout
Comment 12 Commit Notification 2015-10-28 13:50:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9092f96c63c05833ee5319935da1078afe216b55

tdf#94871: sw: fix a frame formatting regression that affects help

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-10-30 11:21:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae846d08b1a18d4cd8f7d59774b3f6686e383280&h=libreoffice-5-0

tdf#94871: sw: fix a frame formatting regression that affects help

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-11-02 08:42:12 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0b9abe1f9cfcf6b43ea3bfc7ae47f649c0992bb&h=libreoffice-4-4

tdf#94871: sw: fix a frame formatting regression that affects help

It will be available in 4.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Michael Stahl (CIB) 2015-11-16 21:34:37 UTC
adding regression keyword here
Comment 16 Regina Henschel 2015-11-16 22:23:29 UTC
I have tested Version: 5.1.0.0.alpha1+
Build ID: f271602f7193ddf584ea58dc6a468e6842d0781e
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-08_22:37:35
Locale: de-DE (de_DE)

The problem still exists, see attached screenshot.
Comment 17 Regina Henschel 2015-11-16 22:24:21 UTC
Created attachment 120587 [details]
screenshot with LO5.1
Comment 18 Michael Stahl (CIB) 2015-11-17 13:49:55 UTC
hmm... that one i can reproduce all the way back to 3.4.6 as well as AOO 3.4.0, so not a regression, removing keyword again
Comment 19 Xisco Faulí 2017-07-13 09:22:07 UTC
Setting Assignee back to default. Please change it back if you're still working on this issue
Comment 20 Olivier Hallot 2019-06-29 18:05:31 UTC
The help pages has now a completely new design and implementation.