Bug 94894 - LO 5.0.3.1x64 Impress -- Master Slides "Available for Use" preview not rendering in Sidebar on initial launch
Summary: LO 5.0.3.1x64 Impress -- Master Slides "Available for Use" preview not render...
Status: RESOLVED DUPLICATE of bug 94370
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-10-08 20:28 UTC by John
Modified: 2015-11-05 22:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sidebar Deck with Master Pages content panel "preparing preview" (31.11 KB, image/png)
2015-10-09 03:48 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2015-10-08 20:28:49 UTC
Using on Mint17.2x64 and Win10x64.

Open Impress. Listing of Master Slides (about 75) takes well over 35 minutes during which the program is completely unresponsive. Master slide previews eventually get listed. Try to select a master slide - nothing happens - menus are blank and the program cannot be closed. After 5 minutes the selected master slide appears on main window but program remains too slow to use. Each time I close and re-open Impress the master slide preview renews itself but I can still select a slide though I have no idea which one it is because the preview slides are busy renewing. 

OK, so I eventually get a master slide while preview list is regenerating (though I had to take a guess at which one I was selecting) but again during this time the program is unresponsive and menu items are blank. Also, again, I cannot close the program because the close dialogue box is also blank and I have to close the program via system settings.

These problems do not exist with writer but are present in both Windows and Linux as mentioned above. Sorry to say that creating a slide presentation in Impress is simply not possible at present, at least for me.
Comment 1 m.a.riosv 2015-10-08 22:09:31 UTC
Hi @John, thanks for reporting.

Please could you set up the LibreOffice version in "Version" field.

Could be possible to attach here a sample file? (Remember this is a public site).

Has the file svg graphics?
Comment 2 m.a.riosv 2015-10-08 22:11:34 UTC
Sorry, I see now the version in the title.
Comment 3 John 2015-10-08 23:16:09 UTC
(In reply to m.a.riosv from comment #1)
> Hi @John, thanks for reporting.
> 
> Please could you set up the LibreOffice version in "Version" field.
> 
> Could be possible to attach here a sample file? (Remember this is a public
> site).
> 
> Has the file svg graphics?


I have no sample file. My description of the bug (as I see it) is when attempting to create a presentation from scratch, from a master slide. I suppose it is possible that some of the master slides have svg graphics but I downloaded most of them from the LO Impress template web page so assumed all was fine.
Comment 4 m.a.riosv 2015-10-09 00:41:00 UTC
Thanks @John, I think I see the issue now.

(Win10x64)

First attempt not too much time, LibreO installed in a SSD.

But running:
Version: 5.1.0.0.alpha1+ Build ID: ac226443522c55ab75cab8eed354b999052135a7-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-09-18_23:26:58

installed on a HD takes a lot to show the previews, even they are selectable and the name is showed with the mouse over.

Seems the slowness is working with master slides.

No processor time consuming

Marked as regression because the issue is not with:
Version: 4.4.7.0.0+ Build ID: 2ca166ebbe2adbd8f129403c7f8e5646c70ab67d
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-10-07_06:28:19
Comment 5 V Stuart Foote 2015-10-09 03:41:51 UTC
On Windows 10 Pro 64-bit with
Version: 5.0.3.1 (x64)
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
Locale: en-US (en_US)

Only seeing  an issue on initial launch with the Master Pages -> "Available for Use" content panel in the Sidebar.

However, if you resize the Sidebar Deck holding the Master Pages content panel--the previews are immediately redrawn. And there is no lag/delay in assigning the master page template to a slide and further editing.

On close/relaunch the previews are immediately available. But closing and clearing user profile results in the same start with no master page previews rendered in the content panel.
Comment 6 V Stuart Foote 2015-10-09 03:48:25 UTC
Created attachment 119445 [details]
Sidebar Deck with Master Pages content panel  "preparing preview"

No impact in activating or deactivating OpenGL. And occurs on *initial* launch of Impress with a new user profile. Subsequent launch behaves normally.
Comment 7 John 2015-10-09 12:44:52 UTC
(In reply to V Stuart Foote from comment #5)
> On Windows 10 Pro 64-bit with
> Version: 5.0.3.1 (x64)
> Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
> Locale: en-US (en_US)
> 
> Only seeing  an issue on initial launch with the Master Pages -> "Available
> for Use" content panel in the Sidebar.
> 
> However, if you resize the Sidebar Deck holding the Master Pages content
> panel--the previews are immediately redrawn. And there is no lag/delay in
> assigning the master page template to a slide and further editing.
> 
> On close/relaunch the previews are immediately available. But closing and
> clearing user profile results in the same start with no master page previews
> rendered in the content panel.

When I have a smaller number of master slides on the system selecting a master for editing is quicker but still slow. This is not initial start up. Even with a small number of masters, in my case 15, Preparing Preview doesn't actually show the preview unless I go to styles and formatting in the sidebar and then change back to master pages. This is the case with Win10x64 as well as Mint17.2x64.

If I have a significant number of master pages, say between 50 and 75 (which I don't think is excessive) as I mentioned in an earlier post, Preparing preview easily takes well over half an hour during which time Impress is non-responsive and I am unable to close the program normally - I have to go to system settings to close the program. Either way, Impress is not usable for me under these circumstances.
Comment 8 richard_g 2015-10-21 08:21:32 UTC
(In reply to V Stuart Foote from comment #5)
> On Windows 10 Pro 64-bit with
> Version: 5.0.3.1 (x64)
> Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
> Locale: en-US (en_US)
> 
> Only seeing  an issue on initial launch with the Master Pages -> "Available
> for Use" content panel in the Sidebar.
> 
> However, if you resize the Sidebar Deck holding the Master Pages content
> panel--the previews are immediately redrawn. And there is no lag/delay in
> assigning the master page template to a slide and further editing.
> 
> On close/relaunch the previews are immediately available. But closing and
> clearing user profile results in the same start with no master page previews
> rendered in the content panel.

Hello,

Version 5.0.3.1 tested on Linux x64 and version 5.0.2.2 tested both on Linux X64 and Vista x86: on close/relaunch, the master pages previews are never available. Each time I launch LibO and create a presentation, I have to resize the Sidebar Deck or click on Gallery then click on Master pages in order to see the preview. 

Richard
Comment 9 Katarina Behrens (CIB) 2015-11-05 22:05:04 UTC

*** This bug has been marked as a duplicate of bug 94370 ***