Bug Hunting Session
Bug 94932 - HTML Save as: table of contents has blank links
Summary: HTML Save as: table of contents has blank links
Status: RESOLVED DUPLICATE of bug 93449
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.0.1.1 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2015-10-10 12:38 UTC by libre
Modified: 2015-10-11 01:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
html output (1.40 KB, text/html)
2015-10-10 13:52 UTC, libre
Details
odt file (10.25 KB, application/vnd.oasis.opendocument.text)
2015-10-10 13:53 UTC, libre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description libre 2015-10-10 12:38:26 UTC
Starting in version 5 (not in 4.2, probably not in 4.4) when I export a document with a table of contents to HTML, it only generates blank links. This is present in 5.0.1 and 5.0.2 (ubuntu ppa). For example:

    <p style="margin-bottom: 0.35cm; line-height: 115%"><font face="Arial, serif"><font size="4" style="font-size: 16pt"><a href="">Önsöz</a></font></font></p>
    <p style="margin-bottom: 0.35cm; line-height: 115%"><font face="Arial, serif"><font size="4" style="font-size: 16pt"><a href="">Kutsal
    Kitap</a></font></font></p>


The references are generated correctly however

<h1 class="western"><a name="__RefHeading___Toc17677_2110837512"></a>Önsöz</h1>
<h1 class="western"><a name="__RefHeading___Toc17679_2110837512"></a>Kutsal
Kitap</h1>
Comment 1 Buovjaga 2015-10-10 13:49:29 UTC
Please attach an example document so we can quickly test.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 libre 2015-10-10 13:52:57 UTC
Created attachment 119480 [details]
html output
Comment 3 libre 2015-10-10 13:53:12 UTC
Created attachment 119481 [details]
odt file
Comment 4 Buovjaga 2015-10-10 14:10:18 UTC
Reproduced. Note that it is from Save as and not export.

This works ok in 4.3.0.1, so regression.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 5 Terrence Enger 2015-10-11 01:05:06 UTC
Working in the daily dbgutil bibisect repository, and bibisecting "in
reverse", I see that the problem disappeared between commit 1f94898
source-hash 098f913 and commit 99e886c source-hash cec9e11.  Between
these two there was source commit fd34680 "tdf#93449 Internal
hyperlinks are not exported corectly in HTML".

So, I am replacing whiteboard bibisectRequest with keyword bisected
and resolving this bug as a duplicate.

To libre@hristiyankitaplar.com. our thanks for taking the time to help
us improve LibreOffice.

Terry,

*** This bug has been marked as a duplicate of bug 93449 ***