Download it now!
Bug 94944 - PDF images broken in generated PDF document
Summary: PDF images broken in generated PDF document
Status: RESOLVED DUPLICATE of bug 94739
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-10 23:15 UTC by Neil Kolban
Modified: 2015-10-13 17:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A zip file containing sample docs and PDFs illustrating problem. (215.63 KB, application/x-zip-compressed)
2015-10-10 23:15 UTC, Neil Kolban
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Kolban 2015-10-10 23:15:42 UTC
Created attachment 119493 [details]
A zip file containing sample docs and PDFs illustrating problem.

I recently installed 5.0.2.2 and now I find that some of the images in generated PDFs are skewed / broken.  Attached to this report is a sample source document, generated PDF and a screen shot of what it looks like to me when viewed on my Adobe viewer.
Comment 1 raal 2015-10-11 08:31:41 UTC
I can not confirm with Version: 5.1.0.0.alpha1+ (x64)
Build ID: 09fc6fef2d03ca8558dd6f0eec45d61ceb282cb5
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-27_22:33:48
and  5.0.2.2 (x64)
ID build: 37b43f919e4de5eeaca9b9755ed688758a8251fe, win7
Comment 2 V Stuart Foote 2015-10-12 14:39:10 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.0.3.1 (x64)
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
Locale: en-US (en_US)

Looking at the .ODT archive, the inserted PNG itself is well formed. Its entry in content.xml seems correct.

Could not reproduce when Printing via Ghostscript (CutePDF), nor with the default Export as PDF, nor with the Export ->  dialog PDF selection.

Nothing jumps out as radically differing when comparing the PDF sources (yours and one of mine).

Sorry but I also can not confirm.  You might try a complete removal clearing user profile--and then reinstall. Please let us know if that resolves it.
Comment 3 V Stuart Foote 2015-10-13 17:46:02 UTC
Setting as duplicate of bug 94739 -- but please still check what an uninstall and a new user profile does.

*** This bug has been marked as a duplicate of bug 94739 ***