Bug 94951 - Table in docx cut off at the end of the page
Summary: Table in docx cut off at the end of the page
Status: RESOLVED DUPLICATE of bug 61594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-11 11:11 UTC by Nikos Platis
Modified: 2016-09-26 16:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The docx file demonstrating the bug (82.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-10-11 11:11 UTC, Nikos Platis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Platis 2015-10-11 11:11:56 UTC
Created attachment 119504 [details]
The docx file demonstrating the bug

The attached document has a long table, which is cut off at the end of the first page. In MS Word it occupies just two pages.
Comment 1 raal 2015-10-11 19:28:55 UTC
I can confirm with Version: 5.1.0.0.alpha1+
Build ID: 8273350ff48f198efc9dc9c5de5519b8cbdc0cb3
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-07_05:54:26

and LO 4.4.2, linux

works OK with LibreOffice 3.5.0 Build ID: d6cde02, regression

Would now be nice to get a bibisect of the bug - https://wiki.documentfoundation.org/QA/HowToBibisect
Please could you do it?
If you need help - feel free to jump into the QA Chat: http://webchat.freenode.net/?channels=libreoffice-qa
Comment 2 Nikos Platis 2015-10-12 05:53:34 UTC
Here it is:

=====================================================
98e26b741cd0eff4b7549d782d7db5a1e98eb1a6 is the first bad commit
commit 98e26b741cd0eff4b7549d782d7db5a1e98eb1a6
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 08:43:40 2012 +0000

    source-hash-c29af1572ad15ac5199a09e5812fb8354c165329
    
    commit c29af1572ad15ac5199a09e5812fb8354c165329
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Wed Aug 22 14:20:32 2012 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Wed Aug 22 14:20:52 2012 +0100
    
        Resolves: rhbz#842292 crash in calling callback whose instance was deleted
    
        Change-Id: I4cc04d59f48b42cc105703daa9983dd7c9f7af62

:100644 100644 f48bbaa1aee4fff06b03f00d856ea90afc8f4bb1 4ef31fbafb0c6fd5facf46ad5e5f2c3151b7a150 M      autogen.log
:100644 100644 77e291a56c8feedd3992dd9c5917420647c9e573 2fe83a37019bb77da337c19f71e03604047b3f5a M      ccache.log
:100644 100644 dd86cf323227505bc8de0a58a14c1512687e5fa0 317825a87e2d4a9fc5e5037476a32d63a9008767 M      commitmsg
:100644 100644 8c0b0ea815bd74a322e365f8f118851ab08188f7 5916ce4e398448c1077ea677f9d0271c22a8f7e5 M      dev-install.log
:100644 100644 76bb1bc9512a65c3fd17fdfb8ded49c13d9ddde8 30ec6ef53acbb8a12c35651e909582d0a870a41b M      make.log
:040000 040000 45f170a51889800a6518fc1f3ecad287e19cc8dc fac44c717ea5908b4edd59ad684c8de62987ee88 M      opt
=====================================================


and the log:

=====================================================
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect bad 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# bad: [51b63dca7427db64929ae1885d7cf1cc7eb0ba28] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect bad 51b63dca7427db64929ae1885d7cf1cc7eb0ba28
# bad: [446a69834acf747d9d18841ec583512ae8fa42e7] source-hash-06a8ca9339f02fccf6961c0de77c49673823b35f
git bisect bad 446a69834acf747d9d18841ec583512ae8fa42e7
# bad: [d2720e99b9e6cb7b099256cc7a6d2b3f907b8d7c] source-hash-7dd6c0a8372810f48e6bee35a11ac4ad0432640b
git bisect bad d2720e99b9e6cb7b099256cc7a6d2b3f907b8d7c
# bad: [98e26b741cd0eff4b7549d782d7db5a1e98eb1a6] source-hash-c29af1572ad15ac5199a09e5812fb8354c165329
git bisect bad 98e26b741cd0eff4b7549d782d7db5a1e98eb1a6
# good: [a72763112e846bcb1c4e4c6f1612ccab6ac73772] source-hash-4662df8a7561ce71ba00accbb5170e10818d6008
git bisect good a72763112e846bcb1c4e4c6f1612ccab6ac73772
# good: [241d451e09694446622f9767fb76db50481c9e32] source-hash-c3aa1cefdc6521d34a2a32c20bae1593e1edb5ba
git bisect good 241d451e09694446622f9767fb76db50481c9e32
# first bad commit: [98e26b741cd0eff4b7549d782d7db5a1e98eb1a6] source-hash-c29af1572ad15ac5199a09e5812fb8354c165329
=====================================================
Comment 3 raal 2015-10-12 06:03:01 UTC
Thanks Nikos for the bibisecting.

Caolán, could you possibly take a look at this one? Thanks
Comment 4 Caolán McNamara 2015-10-13 14:58:55 UTC
That bibisect repo doesn't build every id, just blocks, the true result there is the the regression occurred between

c3aa1cefdc6521d34a2a32c20bae1593e1edb5ba..c29af1572ad15ac5199a09e5812fb8354c165329

its just that my commit is the last in the range (and only affects sd so I'm probably not implicated in this case)
Comment 5 Miklos Vajna 2015-11-28 00:30:34 UTC
This is a problem since edc4861a68e0269b83b17e0ec57912a1ce4220ad, previously the docx importer handled all tables (even wrapped ones) as non-wrapped ones. The root cause is that Writer doesn't support tables that are both being wrapped around, and still can span across multiple pages, but that never worked. So sorry, removing the regression keyword -- implementing that is not trivial and definitely a new feature.
Comment 6 Xisco Faulí 2016-09-26 16:41:00 UTC

*** This bug has been marked as a duplicate of bug 61594 ***