Bug 94952 - Showing slide show with yields 2/3 page with PNG image all black in Linux with HW acceleration
Summary: Showing slide show with yields 2/3 page with PNG image all black in Linux wit...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2015-10-11 12:20 UTC by Ray Holme
Modified: 2019-10-01 13:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
one slide that shows problem (104.51 KB, application/vnd.oasis.opendocument.presentation)
2015-10-11 12:20 UTC, Ray Holme
Details
screenshot (180.35 KB, image/png)
2015-10-11 18:22 UTC, Ray Holme
Details
modified paragraph formatting (107.54 KB, application/vnd.oasis.opendocument.presentation)
2015-10-12 13:11 UTC, Jacques Guilleron
Details
opensuse version screenshot (1.62 MB, image/x-xcf)
2015-10-12 14:39 UTC, Ray Holme
Details
An enlarged background (135.62 KB, application/vnd.oasis.opendocument.presentation)
2015-10-12 17:10 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ray Holme 2015-10-11 12:20:48 UTC
Created attachment 119507 [details]
one slide that shows problem

Fedora 22 fully patched - OS boot level vmlinuz-4.1.10-200.fc22.x86_64
 reproduced with fedora 22 on a 32 bit box too, same os release, same libre office release

This slide show has a left hand side "logo and pretty". With this in place, it looks fine UNTIL I ask for a slide show. A new blank slide show works fine. I cut the 200+ slides down to one and am attaching. The one page is just as bad as the original. The right hand side (2/3-3/4 ?) is covered by a black overlay, the only thing showing through the black overlay is colored text.

I have to give this presentation in two weeks. I hope I do not have to copy all of this to a blank non-pretty version.
Comment 1 tommy27 2015-10-11 12:47:47 UTC
I can load that slideshow with no issues under Win8.1x64 using LibO 4.4.5.1

would you please post a screenshot of the abnormal behaviour you see in your computer?
Comment 2 Ray Holme 2015-10-11 18:22:23 UTC
Created attachment 119519 [details]
screenshot
Comment 3 Ray Holme 2015-10-11 18:24:28 UTC
Attached screen shot (not easy to get to menu and do that) but here it is.

Glad you can see it under slide show in M. land. I can see the screens fine to edit ....; but as soon as I do a slide show - you get this black hole.

:=[
Comment 4 Ray Holme 2015-10-11 20:14:39 UTC
So you are one release off from me (you are using older ...5.1 and I have ...5.2). My conclusion is would be that it is either the newer release OR the Linux release variant. Best of luck. I would hate to make a vanilla version without the background out of desperation.
Comment 5 Jacques Guilleron 2015-10-11 22:49:58 UTC
Hi Ray, Tommy,

works fine also with 
LO 4.4.5.2 Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99 Locale : fr_FR
on Windows 7 Home.
Comment 6 tommy27 2015-10-12 04:46:17 UTC
@Ray
which monitor resolution do you have?

take a look at " Bug 40534 - slide tearing in LARGE screens with hardware acceleration enabled " and tell if your issue is related to that one

I retested your file using LibO 5.1.0.0 alpha and there's no problem during slideshow
Comment 7 Ray Holme 2015-10-12 11:38:46 UTC
This problem happens on my 64 bit Fedora box which has a wide screen and a graphics accelerator. However I first noted it on my 32 bit portable which I was testing the presentation on as that is the machine it will be shown on. It does not have an accelerator nor does it have a wide screen.

I have no problem if I don't have the left hand side graphics (DNA helix and a logo).

Neither machine has a dual monitor and I don't think the problem looks like tearing - it looks like a black overlay rectangle which is opaque and occupies about 2/3 of the screen except for letting colored (red or blue) fonts pass through. (see screenshot).

I will try to have a friend who uses another form of Linux try it.
Comment 8 Ray Holme 2015-10-12 12:44:10 UTC
friend tried and confirmed

  Windows 8.1 LibreOffice 4.4.4.3 Works fine.

will see if someone else can try Linux and/or Mac
Comment 9 Jacques Guilleron 2015-10-12 13:11:15 UTC
Created attachment 119536 [details]
modified paragraph formatting
Comment 10 Jacques Guilleron 2015-10-12 13:13:38 UTC
the overlay begins with the first red character. I slightly changed the paragraph formatting. Does this cha
Comment 11 Jacques Guilleron 2015-10-12 13:17:09 UTC Comment hidden (obsolete)
Comment 12 Ray Holme 2015-10-12 14:38:55 UTC
problem reproduced in LO 4.3.7.2 on opensuse 13.2
 better screenshot attached next
Comment 13 Ray Holme 2015-10-12 14:39:42 UTC
Created attachment 119537 [details]
opensuse version screenshot
Comment 14 Ray Holme 2015-10-12 14:41:41 UTC
I sent one slide of a nearly 200 page presentation.

The overlay is consistent in every slide. It starts the same place and many screens have NO red or blue.

The consistent thing is that red and blue show THROUGH the black.
Comment 15 Ray Holme 2015-10-12 15:04:03 UTC
OK, two more notes.

My opensuse friend observed (see screenshot) that the dna helix is in the middle not on the left as it should be in the original editable version. I would also note that the logo in the lefthand corner is NOT visible in the editable version. The slide show version in opensuse is identical to what I see - helix and logo fine, presentation over-blacked.

My son tried on a mac. The slide show does not show all on the slide fully but it is NOT blackened. Another mac friend says all looks fine (more likely to have most current software as a developer).
Comment 16 Jacques Guilleron 2015-10-12 17:10:25 UTC
Created attachment 119541 [details]
An enlarged background

I think the logo in background is not large enough. I tried aanother image combining the logo and a white background and saved it in LO 4.3.7.2. is iot the good idea?
Comment 17 Ray Holme 2015-10-12 19:34:55 UTC
Summary of bug:

  works on Windows

  on Mac and openSuse, kind of works but
    the "edit" window shows the left DNA strand in the middle
           and the top left name brand logo is gone
    however they show up OK on the slide show for the MAC
    for openSuse, the slide show acts like under Fedora (below)

   for fedora, the edit window is fine
     the slide show appears with EVERY slide having an almost
       opaque black box covering the right 2/3 of the screen
       the only thing that shows through the black box
        is color text
     it is not known when this problem began presentations
       without the base graphics work fine.
Comment 18 Ray Holme 2015-10-12 19:36:13 UTC
Jacque, I can change the size of the logo - I guess. I will try that but sure don't understand why that is a problem.
Comment 19 Ray Holme 2015-10-12 19:59:49 UTC
This is DEFINITELY due to the logo in the upper left corner of the master page.

When I remove it, the show works fine.

To be honest, I don't even remember how I got it there as I did it weeks ago.

I would like to have a logo somewhere on the master page, but it does NOT have to be in the upper left over the DNA backdground.

I will see if I can edit DNA.otp and get it to work.
Comment 20 Ray Holme 2015-10-12 20:52:18 UTC
I went back to just having a DNA background; then added another image to the master (perhaps not the same size) - in any case - IT WORKED.

The problem remains but I have worked around it and the presentation slide show works JUST FINE.

:=]
Comment 21 Ray Holme 2015-10-13 15:18:21 UTC
Thanks Jacques.

I enlarged the logo and it works fine.

I would suggest that this is a bug still but has a workaround.

:=]
Comment 22 Buovjaga 2015-10-22 09:34:49 UTC
Confirmed.
Opengl setting does not matter.

Version: 5.0.2.2
Build ID: 5.0.2.2 Arch Linux build-3
Locale: fi-FI (fi_FI.UTF-8)
Gnome Shell 3.18.1
Comment 23 QA Administrators 2016-11-08 11:15:20 UTC Comment hidden (obsolete)
Comment 24 Timur 2019-04-30 14:55:04 UTC Comment hidden (obsolete)
Comment 25 Timur 2019-10-01 13:08:13 UTC
Repro 6.4+ only in Linux with HW acceleration (normal resolution).