Download it now!
Bug 94983 - Line data series properties being controlled in the area content panel
Summary: Line data series properties being controlled in the area content panel
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 95034 (view as bug list)
Depends on:
Blocks: Chart-Sidebar
  Show dependency treegraph
 
Reported: 2015-10-12 12:58 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-10-15 10:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-10-12 12:58:08 UTC
Steps:
1) Open attachment 119527 [details]
2) Edit the line chart
3) Click on one of the data series lines
4) Notice that the line color and transparency are controlled in the area content panel rather than in the line content panel

The area content panel shouldnt be shown in this type of chart type as the data series are only lines.

Version: 5.1.0.0.alpha1+
Build ID: 143fb0a4b5d4ab69d4928299d8112ab95d99870a
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-11_00:06:41
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2015-10-12 14:38:40 UTC
I can confirm with Version: 5.1.0.0.alpha1+
Build ID: 8273350ff48f198efc9dc9c5de5519b8cbdc0cb3
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-07_05:54:26
Comment 2 Markus Mohrhard 2015-10-12 21:18:43 UTC
All charts support both line and area properties and there is nothing I can do.
Comment 3 Yousuf Philips (jay) (retired) 2015-10-14 09:16:20 UTC
*** Bug 95034 has been marked as a duplicate of this bug. ***
Comment 4 Luke 2015-10-14 20:56:49 UTC
Markus,
I also noticed this issue. I'm fine with keeping both, but the line color should be controlled under line just like the shape sidebar does. Is this possible?
Comment 5 Yousuf Philips (jay) (retired) 2015-10-15 10:58:44 UTC
(In reply to Luke from comment #4)
> I also noticed this issue. I'm fine with keeping both, but the line color
> should be controlled under line just like the shape sidebar does. Is this
> possible?

Marcus said on irc

<moggi> the panels map to the FillProperties and LineProperties in chart2's UNO API
<moggi> as long as they are offered by an object we use them directly and then the view code decides how to interpret them
<moggi> data points are just an ugly case, they provide both but not all chart types make use of all the properties
<jphilipz> weird that line charts have FillProperties when it has no Area tab
<moggi> all data series and data points have these properties
<moggi> they are all implemented by the same core object and just the rendering is different based on the chart type