Download it now!
Bug 95015 - UI: Appcrash in Remote Desktop Session when exiting slide show view
Summary: UI: Appcrash in Remote Desktop Session when exiting slide show view
Status: RESOLVED DUPLICATE of bug 100151
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-10-13 16:30 UTC by mschedler
Modified: 2016-09-23 15:22 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Backtrace for crash on LO 5.0.2.2 (7.71 KB, text/plain)
2015-11-10 18:03 UTC, mschedler
Details
Backtrace for crash on LO 5.0.3.2 (7.53 KB, text/plain)
2015-11-10 18:04 UTC, mschedler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mschedler 2015-10-13 16:30:16 UTC
When viewing any Impress Presentation in Remote Desktop session on Windows Server 2008 R2 Enterprise (SP1), exiting the slide show view causes LO to crash every time even a blank or text only, single page presentation. Tested with RDP clients on Windows 7, Wyse Thin Client and Linux. RDP session is full screen, 16 bit color and all visuals disabled (desktop background etc). Remote Desktop server is dual processor Xeon, 64 bit with 32GB RAM. Using LO 5.0.2.2 x86_64 (Fresh). Everything works fine until user exits the slide show (escape key or end of slideshow) and then LO crashes.
Comment 1 Julien Nabet 2015-11-07 17:07:14 UTC
Any chance to retrieve an useful backtrace (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)?

Also, you may give a try to brand new 5.0.3 version.
Comment 2 mschedler 2015-11-09 17:43:55 UTC
I can do both...

I will add that, after some additional tinkering, I discovered that disabling the "Hardware Acceleration" option seems to fix the issue.
Comment 3 mschedler 2015-11-10 18:03:46 UTC
Created attachment 120458 [details]
Backtrace for crash on LO 5.0.2.2
Comment 4 mschedler 2015-11-10 18:04:42 UTC
Created attachment 120459 [details]
Backtrace for crash on LO 5.0.3.2
Comment 5 Caolán McNamara 2016-09-23 15:22:45 UTC

*** This bug has been marked as a duplicate of bug 100151 ***