Bug Hunting Session
Bug 95030 - FILESAVEAS: LibreOffice segfaults upon clicking save as. (gtk3.18)
Summary: FILESAVEAS: LibreOffice segfaults upon clicking save as. (gtk3.18)
Status: RESOLVED DUPLICATE of bug 94936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-14 02:47 UTC by Michael Heyns
Modified: 2015-10-14 07:58 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
trace of Writer via --backtrace argument. (11.74 KB, text/x-log)
2015-10-14 02:47 UTC, Michael Heyns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Heyns 2015-10-14 02:47:27 UTC
Created attachment 119579 [details]
trace of Writer via --backtrace argument.

I believe this could have something to do with changes to the gtk filechooser, but I am not certain.

Fresh install of Arch Linux along with GNOME 3.18.1 and LibreOffice 5.0.2.2.
Problem was not present when running GNOME 3.16.

Happens in all applications after selecting "Save As.../a Copy" but before the filechooser dialog appears.

Opening files functions.

Problem can be worked around by using SAL_USE_VCLPLUGIN=gtk instead.
Comment 1 Maxim Monastirsky 2015-10-14 07:58:48 UTC

*** This bug has been marked as a duplicate of bug 94936 ***