Bug 95046 - 5.0.2.1RC1 Spinning wheel on almost any operation on OSX 10.11
Summary: 5.0.2.1RC1 Spinning wheel on almost any operation on OSX 10.11
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.2.1 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-14 11:07 UTC by Martin Srebotnjak
Modified: 2016-01-27 19:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2015-10-14 11:07:55 UTC
Running 5.0.2.1 RC1 on OSX 10.11 brings up spinning wheel all the time, use of LO is unpossible.
Comment 1 Alex Thurgood 2015-10-18 19:05:52 UTC
No repro on

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale : fr-FR (fr.UTF-8)

OSX 10.11

Please try wotht he latest production release of LibreOffice.

Please also provide more details about your environment :

- LibreOffice from AppStore or LibreOffice from TDF ?
- Java version(s) ?
- assistive technologies (screen readers, VoiceOver, zoom, etc)?
Comment 2 Martin Srebotnjak 2015-10-18 20:20:51 UTC
I think this is the cause, if I am correct.
I get this error with both LO from TDF and from Vanilla LO (Apple Store).
The reason is that whenever Java is needed:
- Vanilla LO does not have Java enabled and the wheel starts rotating;
- LO from TDF wants to run Java, but finds only Java 8 and it is not enough, it wants also Java 6;

So, the solution would be - install Java 6 on OSX. But:
I upgraded my OS X to El Capitan. Both Java installations disappeared. I reinstalled both or seemed to do so, but only Java 8 is displayed on the Java selection menu in LO Advanced Settings.

Either El Capitan does not allow Java 6 to install or it does not install properly.

Why does opening a doc or docx need Java installed - I do not know.
Comment 3 Alex Thurgood 2015-10-18 21:27:59 UTC
(In reply to miles from comment #2)
> I think this is the cause, if I am correct.
> I get this error with both LO from TDF and from Vanilla LO (Apple Store).
> The reason is that whenever Java is needed:
> - Vanilla LO does not have Java enabled and the wheel starts rotating;
> - LO from TDF wants to run Java, but finds only Java 8 and it is not enough,
> it wants also Java 6;


The dependency on Java6 is known, and will remain so until Oracle can fix a bug in the way it instantiates the Jvm in process.


> So, the solution would be - install Java 6 on OSX. But:
> I upgraded my OS X to El Capitan. Both Java installations disappeared. I
> reinstalled both or seemed to do so, but only Java 8 is displayed on the
> Java selection menu in LO Advanced Settings.
> 

That is normal, the Java8 installation masks the Java6 installation.

> Either El Capitan does not allow Java 6 to install or it does not install
> properly.
> 
> Why does opening a doc or docx need Java installed - I do not know.


LO for Osx comes with a bundled extension that requires java and this gets activated when you open a doc or docx file.
Comment 4 Martin Srebotnjak 2015-10-18 21:31:45 UTC
So, LO does not work on OSX 10.11?
Comment 5 Alex Thurgood 2015-10-19 05:13:49 UTC
Sure it does, read comment 1
Comment 7 Martin Srebotnjak 2015-10-19 05:27:14 UTC
But I cannot install Java 6 when Java 8 is already present so - it does not work on my OSX or any upgraded OSX to 10.11. Unless someone provides instructions how to make Java 6 install and be seen by LO.
And that should all be included in the release notes and installation instructions for LO.
Comment 8 steve -_- 2015-10-19 06:41:52 UTC
I agree that the dependency on Java is a bit odd. What if the user does not want to use Java at all? Java can be disabled in LO under LO > Preferences > Advanced.

I wonder what extension delivered by default is requiring Java.
Comment 9 Alex Thurgood 2015-10-19 12:10:50 UTC
(In reply to steve -_- from comment #8)
> I agree that the dependency on Java is a bit odd. What if the user does not
> want to use Java at all? Java can be disabled in LO under LO > Preferences >
> Advanced.
> 
> I wonder what extension delivered by default is requiring Java.

Not necessarily an extension, but soem code that requires Java :

- XSLT import/export filters ?
- spell checkers ?
- NLP Solver ?
- wikimedia extension ?
- GDocs extension ?
Comment 10 Alex Thurgood 2015-10-19 12:15:07 UTC
(In reply to miles from comment #7)
> But I cannot install Java 6 when Java 8 is already present so - it does not
> work on my OSX or any upgraded OSX to 10.11. Unless someone provides
> instructions how to make Java 6 install and be seen by LO.

On the contrary, you can (I did). When I upgraded to OSX 10.11, the upgrade hosed my Java6 installation, but kept my Oracle Java8 installation.

The first time I launched LO, I was told that the application required Java6 and Apple provided me with a link to launch Safari and download the corresponding DMG. Once I did that, I could start LO again without issue and even though it isn't seen in the JVM preferences under Advanced in the LO Preferences dialog (Oracle Java8 is shown instead), it still works.


> And that should all be included in the release notes and installation
> instructions for LO.

Please report this particular item as a separate bug against documentation or installation.
Comment 11 Martin Srebotnjak 2016-01-27 19:42:09 UTC
Yeah, lets just say it is not our problem, that will just make it go away.