Bug 95098 - format cells for automatic line wrapping
Summary: format cells for automatic line wrapping
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-15 20:48 UTC by gmarco
Modified: 2015-10-30 07:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot for format (69.41 KB, image/jpeg)
2015-10-15 20:48 UTC, gmarco
Details
screenshot for help (149.47 KB, image/jpeg)
2015-10-15 20:50 UTC, gmarco
Details
sample calc test (18.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-10-16 08:05 UTC, gmarco
Details
new scrrenshot (177.31 KB, image/jpeg)
2015-10-16 08:07 UTC, gmarco
Details
new screenshot (147.42 KB, image/jpeg)
2015-10-16 08:08 UTC, gmarco
Details
new screenshot (149.17 KB, image/jpeg)
2015-10-16 08:09 UTC, gmarco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gmarco 2015-10-15 20:48:50 UTC
Created attachment 119651 [details]
screenshot for format

I'll wish to format cells for automatic line wrapping but I can't view the location where select it.
One of the attachments displays what I can see in Format - Cells - Alignment, the other one what it is is said in the help (in the English version is: "3. Select Wrap text automatically") but I can't find the field to select.
Comment 1 gmarco 2015-10-15 20:50:03 UTC
Created attachment 119652 [details]
screenshot for help
Comment 2 Cor Nouws 2015-10-15 21:06:27 UTC
Hi gmarco,

Thanks for writing here and using LibreOffice!

Please look at Scorrimento testo automatico.

But please don't ask those questions here :) This is not a help forum.

We have great community support in case you want to ask first
  http://www.libreoffice.org/get-help/community-support/

Regards,
Cor
Comment 3 gmarco 2015-10-16 08:05:39 UTC
Created attachment 119662 [details]
sample calc test
Comment 4 gmarco 2015-10-16 08:07:17 UTC
Created attachment 119663 [details]
new scrrenshot
Comment 5 gmarco 2015-10-16 08:08:17 UTC
Created attachment 119664 [details]
new screenshot
Comment 6 gmarco 2015-10-16 08:09:31 UTC
Created attachment 119665 [details]
new screenshot
Comment 7 gmarco 2015-10-16 08:10:30 UTC
(In reply to Cor Nouws from comment #2)

Hi Cor, thanks for your reply but I already had tried having no result.
First, help says "selezionate Ritorno a capo automatico" and not "scorrimento testo automatico" (I don't know in English, but in Italian they have a different meaning).
Then, however, I had tried without result as you can see by the new attachments.
I am not able to understand why, so I thought it was a bug.
May you explain the case?
Comment 8 Cor Nouws 2015-10-16 11:41:36 UTC
Hi gmarco,

It has to do with the row height then.
Format > Row > Optimal height (0,0 and checked) > OK
 solved
no idea where that went wrong in you case.

Cheers
Cor
Comment 9 gmarco 2015-10-16 17:25:30 UTC
(In reply to Cor Nouws from comment #8)
Hi Cor, thanks, now that is OK.
May be a warning in the help could be usefull?

You say "no idea where that went wrong in you case".
The only thing I may suppose is that the original spreadsheet was an xls by Excel. Indeed that doesn't happen in a new ods (perhaps Calc has rows optimal height presetted?)
Comment 10 Cor Nouws 2015-10-16 19:51:30 UTC
Hi Marco,

(In reply to gmarco from comment #9)
> Hi Cor, thanks, now that is OK.

Nice :)

> May be a warning in the help could be usefull?

You mean with the text on line wrapping? Would be good yes. Mind to file a bug (enhancement) for that ?

> You say "no idea where that went wrong in you case".
> The only thing I may suppose is that the original spreadsheet was an xls by
> Excel. Indeed that doesn't happen in a new ods (perhaps Calc has rows
> optimal height presetted?)

It could be some conversion problem?
If you have a clear test case, xls/xlsx with this and that formatting, opening in Libre...
Hmm, querying for xls and wrap:
  https://bugs.documentfoundation.org/show_bug.cgi?id=32950

Think that is exactly the same, don't you think so?
Comment 11 gmarco 2015-10-17 08:47:34 UTC
(In reply to Cor Nouws from comment #10)
> It could be some conversion problem?
> If you have a clear test case, xls/xlsx with this and that formatting,
> opening in Libre...
> Hmm, querying for xls and wrap:
>   https://bugs.documentfoundation.org/show_bug.cgi?id=32950
> 
> Think that is exactly the same, don't you think so?

Very good! I'm not able to open the bug attachments but the question really seems the same.
I've just tested and commented the bug 32950 with my conclusions attaching two samples. Look at that, please. (Maybe someone will change the status)

> You mean with the text on line wrapping? Would be good yes. Mind to file a
> bug (enhancement) for that
Yes I'll do also because help says "Selezionate Ritorno a capo automatico" (it is a right translation) but Calc-Format menu displays "Scorrimento testo automatico" and this has a different meaning and is a misunderstanding translation.
Comment 12 gmarco 2015-10-17 10:13:20 UTC
Hi Cor, I just posted an enhancement (95131)
Comment 13 Cor Nouws 2015-10-17 14:58:13 UTC
Hi marco,
thamks! currently working on a pile stuff todo before a much needed week off.. so not sure if can check all soon ;)

(pls ping in the issue if I forget it..)
Comment 14 gmarco 2015-10-17 20:10:52 UTC
(In reply to Cor Nouws from comment #13)
> Hi marco,
> thamks! currently working on a pile stuff todo before a much needed week
> off.. so not sure if can check all soon ;)
> 
> (pls ping in the issue if I forget it..)

Well Cor, I'll remember you, thanks
Comment 15 gmarco 2015-10-28 17:39:22 UTC
(In reply to Cor Nouws from comment #13)
> Hi marco,
> thamks! currently working on a pile stuff todo before a much needed week
> off.. so not sure if can check all soon ;)
> 
> (pls ping in the issue if I forget it..)

Hi Core,,
is it time for pinging ?