Bug 95151 - Endless autosave loop
Summary: Endless autosave loop
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoSave-AutoRecovery-Backup
  Show dependency treegraph
 
Reported: 2015-10-18 10:23 UTC by Daniil Bratashov
Modified: 2019-12-07 17:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniil Bratashov 2015-10-18 10:23:14 UTC
If the file is opened from temporary folder with no write access (mail folder in my case), it is opened in read-only mode. If Writer tries to autosave file, there is endless loop, disabling all interface interaction, showing blinking line about failed attempt to autosave in status bar, and there is no option except to crash the entire office and start edition again after document recovery (in its initial state).
Comment 1 Jean-Baptiste Faure 2015-10-27 06:37:50 UTC
Not reproducible for me with LibreOffice 5.0.4.0+ built at home under Ubuntu 15.04 x86-64.

Please, could you test again with the first release candidate of version 5.0.3, available from here: https://www.libreoffice.org/download/pre-releases/

Best regards. JBF
Comment 2 Daniil Bratashov 2015-10-27 13:03:38 UTC
I've debugged this a little (and crashed my reply to the reviewer of the article triple times), seems that main source of the problem is formula inside the document. It was initially in docx format of MS office 2007/2010, when I change it and try to save, I'm getting endless loop while saving the document (or when autosave is triggered). I can try to made a similar document in MS Office, without personal information inside.
Comment 3 QA Administrators 2016-11-08 12:23:52 UTC Comment hidden (obsolete)
Comment 4 Daniil Bratashov 2016-11-08 13:06:47 UTC
Seems that I've lost all tracks for this bug.
Comment 5 Alberto Salvia Novella 2019-12-07 17:46:19 UTC
Potential duplicate:
"Endless auto-save: Data lost"
https://bugs.documentfoundation.org/show_bug.cgi?id=129269