Bug 95166 - Impress corrupts PPTX containing Shapes with Picture Fill
Summary: Impress corrupts PPTX containing Shapes with Picture Fill
Status: RESOLVED DUPLICATE of bug 96051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-10-19 00:58 UTC by Luke
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error Message (5.86 KB, image/png)
2015-10-19 00:58 UTC, Luke
Details
Even Simpler Example (131.51 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-10-19 00:59 UTC, Luke
Details
Corrupted file after saved with Impress 5.0.2 (132.45 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-10-20 18:22 UTC, Dennis Roczek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-10-19 00:58:02 UTC
Created attachment 119731 [details]
Error Message

Steps to reproduce:
1. In PowerPoint Insert Shape
2. Shape Fill -> Picture -> Insert
3. Save 
4. Open in Impress
5. Roundtrip file from 3

See attachment 119730 [details] for a simple example.
Comment 1 Luke 2015-10-19 00:59:38 UTC
Created attachment 119732 [details]
Even Simpler Example
Comment 2 Luke 2015-10-19 06:50:22 UTC
I could not reproduce this with Impress 4.3.
Comment 3 Dennis Roczek 2015-10-20 18:22:15 UTC
Created attachment 119798 [details]
Corrupted file after saved with Impress 5.0.2

confirmed with 
Version: 5.0.2.2 (x64)
Build-ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Gebietsschema: de-DE (de_DE)

see attached "corrupted" file (simple example opened with impress and saved as a new file) which is repairable by powerpoint 2013. A Message like "some elements were removed, please check slides" appear.
Comment 4 Buovjaga 2015-10-20 18:33:49 UTC
NEW per comment 3
Comment 5 raal 2015-10-22 07:56:04 UTC
bibisect-win32-5.0, oldest version contains bug too.
git checkout oldest: Version: 4.5.0.0.alpha0+
Build ID: 57d6b92b69a31260dea0d84fcd1fc5866ada7adb
Comment 6 raal 2015-12-06 08:58:01 UTC
This seems to have begun at the below commit.
Adding Cc: to Zolnai Tamás ; Could you possibly take a look at this one?
Thanks
 a517caa859adca6b8c80c8529bfe7bfb68c61ddf is the first bad commit
commit a517caa859adca6b8c80c8529bfe7bfb68c61ddf
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sun Mar 15 02:49:47 2015 +0800

    source-hash-b3d50feaa87b670baf68288974005ac26ad31736
    
    commit b3d50feaa87b670baf68288974005ac26ad31736
    Author:     Zolnai Tamás <tamas.zolnai@collabora.com>
    AuthorDate: Tue Sep 16 17:51:12 2014 +0200
    Commit:     Zolnai Tamás <tamas.zolnai@collabora.com>
    CommitDate: Wed Sep 17 09:59:50 2014 +0200
    
        bnc#584721: Import subtitle block to master slides
    
        For some reason subtitle block was skipped for
        layouts. It seems we can enable it for layout too,
        it appears well on master slides.
    
        Change-Id: I23ec7d4fcce045099bfca9e94a8c9335beaf7468
Comment 7 Luke 2015-12-08 02:27:03 UTC
Even though this is an older bug, I'm marking it as a dupe of Bug 95166 since that appears to be a more generalized version of this bug.

*** This bug has been marked as a duplicate of bug 96051 ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 11:03:40 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]