Bug 95178 - Export as PDF: Dialog-Box in Calc is too big with German UI
Summary: Export as PDF: Dialog-Box in Calc is too big with German UI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other All
: medium minor
Assignee: Adolfo Jayme
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.2
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export-Options-Dialog
  Show dependency treegraph
 
Reported: 2015-10-19 13:47 UTC by k-j
Modified: 2017-08-14 13:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison English and German UI (57.48 KB, application/vnd.oasis.opendocument.text)
2015-10-19 13:47 UTC, k-j
Details
Quick-and-dirty patch (12.66 KB, patch)
2015-10-28 07:14 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description k-j 2015-10-19 13:47:17 UTC
Created attachment 119747 [details]
comparison English and German UI

In German UI the dialog-box for "Export as PDF" is much bigger than in Englisch UI and there is many white space.

Tested in 5.0.2.2 WIN10 32bit and 5.1.0.0.alpha1+
Build-ID: 2511a21841dd9dec735a53add8174e47d24deb88 TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-13_23:26:46

The same "problem" with Russian and Japanese UI but not with Arabic UI (tested with 5.1.0alpha).
For more information about the discussion (in German): http://listarchives.libreoffice.org/de/discuss/msg18978.html
Comment 1 k-j 2015-10-19 13:50:32 UTC
Thorsten draws an work around by making the dialog-box resizable:

http://listarchives.libreoffice.org/de/discuss/msg18985.html
Comment 2 Steve Edmonds 2015-10-19 22:10:12 UTC
Would this make it a regression then.
Comment 3 Adolfo Jayme 2015-10-20 05:42:50 UTC
Don’t be misled into thinking that making the dialog resizable will fix this bug, because it’s the *minimal size* in which is generated (i.e., you can’t resize it smaller, only bigger).

The dialog also appears too big in Spanish, by the way, because the strings are longer.
Comment 4 Adolfo Jayme 2015-10-28 07:14:52 UTC
Created attachment 120036 [details]
Quick-and-dirty patch

The attached patch mitigates the excessive blank space problem by removing the “homogeneous” property from the grids. Unfortunately, this makes the options seem misaligned when you switch tabs in the PDF Options dialog.
Comment 5 Commit Notification 2017-08-12 00:02:36 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f3baf45723a11987c0a0ddaa1ca1cebafcccde3

tdf#95178 Homogeneous columns are a huge waste of space

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Adolfo Jayme 2017-08-12 00:03:09 UTC
I dunno why I didn’t push that patch back then, shame on me
Comment 7 Commit Notification 2017-08-14 13:48:49 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2aa1c7d95ee35c39498ca8a62e8cd7f50941c07b&h=libreoffice-5-4

tdf#95178 Homogeneous columns are a huge waste of space

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.