Bug Hunting Session
Bug 95206 - Fileopen: Page number is 0 instead of 1 on all sheets, except the 1st (affects XLS and XLSX always and ODS depending on document property)
Summary: Fileopen: Page number is 0 instead of 1 on all sheets, except the 1st (affect...
Status: RESOLVED DUPLICATE of bug 95612
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-20 20:37 UTC by OfficeUser
Modified: 2017-03-12 01:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
issue.ods (11.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-10-20 20:37 UTC, OfficeUser
Details
XLSX with page numbers in header shown OK only for the 1st sheet (13.70 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-10-26 12:42 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2015-10-20 20:37:32 UTC
Created attachment 119801 [details]
issue.ods

Hi,

please...

- Open the attached spreadsheet issue.ods

- Open the page preview

Note: On thew bottom left there is "Seite 0 von 1" (English translation: Page 0 of 1)

I don't know why the page number starts with 0. It should be 1. It looks like a bug. This only happens for the second sheet "Oktober 2015".
Comment 1 OfficeUser 2015-10-20 20:38:54 UTC
Bug 77111 describes a similar issue in Writer.
Comment 2 m.a.riosv 2015-10-20 23:59:25 UTC
Hi @OfficeUser, thanks for reporting.

In your file is disable the first page number in the Format/Page/Sheet.
Comment 3 OfficeUser 2015-10-21 19:00:25 UTC
Hi m.a.riosv,

thanks for your comments. But in fact we have a bug here.

1.
The documentation says:
"Select this option if you want the first page to start with a number other than 1."
https://help.libreoffice.org/Calc/Sheet_1

2.
For the first sheet of my attached ods-file, the page number starts correctly with 1.

3.
Starting the second sheet with 0 and the first one with 1 by default would not make sense.

==> Re-opened.
Comment 4 m.a.riosv 2015-10-21 21:39:40 UTC
Then we need to know now, where the bug is, in the program or in the help, because it's not possible set up '0' as first page.

In fact creating a new spreadsheet, has the option enable and with 1 as first page, for all LibreOffice versions beginning with 3.3.4.
Comment 5 Timur 2015-10-22 09:54:21 UTC
You cannot set your own bugs as NEW, only Unconfirmed. 
I confirm the problem, but before confirming the bug, we need to know how your document was created. If we create a new document with some recent version - page numbers are correct. 
Current behavior started from LO 3.3. OO also showed 0 but with some text it would show 3, so no regression here.
Comment 6 OfficeUser 2015-10-22 20:10:50 UTC
@ Timur:

Thanks for your comments.

The document is based on a .xlsx input.

I summarize the situation...
1) Imported .xlsx or .xls files have "First page number" UNCHECKED
2) New Calc documents have "First page number" CHECKED by default
3) If "First page number" is UNCHECKED, we have the bug that the second (and maybe also a third, fourth, ...) sheet starts with page number 0 (initial bug description)


Fact is that behavior 3) does not make sense, is against the documentation and is not what a user expects.


For me the situation looks like...

1) Is correct behavior.
2) Could be a work around that has been introduced in build 3.3.4 to avoid 3).


So a proper solution for my understanding is to...
1) Keep as it is
2) UNCHECK "First page number" by default for new spreadsheets
3) Writing a patch that if "First page number" is UNCHECKED, all sheets start with page number 1 as described in the documentation and as expected by the user.
Comment 7 OfficeUser 2015-10-22 20:12:44 UTC
I have reset Importance to "normal" since files imported from Excel are always affected by this bug.
Comment 8 OfficeUser 2015-10-22 20:14:10 UTC
Correction:

"The document is based on a .xlsx input."
should be
"The document is based on a .xlsx import."
Comment 9 Timur 2015-10-26 12:11:42 UTC
According to the description, I change the title to: "Fileopen: Page number is 0 instead of 1 in XLSX on all sheets, except the 1st".
I'm not aware of a workaround.

But, for the future, I repeat, you cannot set your own bugs as New, only Unconfirmed.
Comment 10 Timur 2015-10-26 12:42:59 UTC
Created attachment 119966 [details]
XLSX with page numbers in header shown OK only for the 1st sheet
Comment 11 QA Administrators 2016-11-08 11:55:45 UTC Comment hidden (obsolete)
Comment 12 OfficeUser 2016-11-08 13:29:24 UTC
I can still reproduce this bug with LibreOffice 5.2.3.2.
Comment 13 Katarina Behrens (CIB) 2017-03-03 17:32:08 UTC
Hello good people, 

it would be nice if some1 tried with a daily build (as of today or tomorrow 4th March) and tested if this issue persists. And if it doesn't, mark it as duplicate of bug#95612

Thankyouverymuch :)
Comment 14 m.a.riosv 2017-03-12 01:58:54 UTC
Tested with
Version: 5.3.2.0.0+
Build ID: acd58ceaa1d792d0a16c270c56ff727321fb2aac
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2017-03-10_19:46:34
Locale: es-ES (es_ES); Calc: group

Looks fine for me.

*** This bug has been marked as a duplicate of bug 95612 ***