Bug 95265 - Format all comments does not persist
Summary: Format all comments does not persist
Status: RESOLVED DUPLICATE of bug 91596
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-23 03:59 UTC by Luke Kendall
Modified: 2015-10-24 16:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Showing very bad comment text refresh (252.15 KB, image/png)
2015-10-23 03:59 UTC, Luke Kendall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2015-10-23 03:59:57 UTC
Created attachment 119894 [details]
Showing very bad comment text refresh

I selected Format All Comments from a comment drop-down menu, changed the font size (from 12 to 10), then saved the file, then re-opened it.  A few more comments were set to 10 point, but after those few, all the remaining comments had not had their font size changed. 

Note that the text in most of the comments on display was redrawn incorrectly immediately after the font size change: it looked like it "erased" the text at the wrong size font size and then re-drew it over the top. On one occasion, one of the comments was simply blacked-out (see screenshot). The redraw error quickly fixes itself (almost any action will make the window refresh correctly).

A related problem? : I scrolled away from a comment onto a new page, clicked on the Drop-down menu icon on a comment on the new page, and LO scrolled back to the previous comment and opened the menu for that earlier comment.  It did this repeatedly, until I actually clicked into the text of the later comment whose drop-down menu I was opening. On another occasion, without scrolling back to the previous comment, instead the Character format dialogue opened up showing the font size of the previous comment, not the selected one.
Comment 1 Buovjaga 2015-10-24 16:28:21 UTC
It seems this was previously reported, too :)

*** This bug has been marked as a duplicate of bug 91596 ***