Download it now!
Bug 95267 - Copy of comment from one doc to another changes the comment text font size
Summary: Copy of comment from one doc to another changes the comment text font size
Status: RESOLVED DUPLICATE of bug 103064
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2015-10-23 05:14 UTC by Luke Kendall
Modified: 2017-04-20 16:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2015-10-23 05:14:13 UTC
Because there is no mechanism to set the default comment text size in LO, I set the font size to the size I wanted for all comments in the source document, so that when I copied selected comments across into a new document, the font size would be small enough so that I wouldn't have to scroll the text to read the comments.  Unfortunately, the comment text size is reset to some hidden default. (12 pt).  

(Incidentally, I want to set just the comment text size to 10 or even 9 or 8.  I certainly don't want any other text default set to be so small.  So if the comment default size is coupled with some other text default size, that wouldn't help.)
Comment 1 Buovjaga 2015-10-24 16:56:25 UTC
Not reproduced.
I tried both with formatting directly and Format all comments.
Selected comment text, copied, pasted to a comment in another document.
Even saved & reloaded fine.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 2 A (Andy) 2015-11-07 21:41:04 UTC
For me also not reproducible with LO 5.0.3.2, Win 8.1

Could this maybe be a Linux only issue?
Comment 3 Luke Kendall 2015-11-08 01:17:55 UTC
The default font size for comments on Linux appears to be 12pt (and the font: Liberation Serif).  I have used Format All Comments to set this to 10pt in both the source and target documents.

If I copy a comment from the source to the target, the pasted comment is pasted as 12 pt.

When you tried to reproduce it, could you try first formatting all the source document comments' font size to something smaller than the default font size?  Perhaps that makes a difference?

I have noticed a possibly-related problem, too: 
I have copied some comments "ahead" of where I am editing currently;
the editing involves changes to the text, and sometimes I copy more comments across into the target text I've just changed;
despite having used "Format All Comments", sometimes when I look at the comments "ahead", they have reverted to 12 pt.
Oh, I just went skimming back earlier in the document, and found one *earlier* comment that had also reverted to 12 pt.

I have the zoom factor in the source document set to 80%, that of the target set to 110%, in case that's relevant?

Also, the body font and paragraph styles in the source document are quite different to that of the target: source is Times New Roman 14pt, with pretty much the default paragraph styles, I think; the target document uses the CreateSpace template, so has quite different paragraph styles, and the body text is Garamond 9 (which seems to somehow work, even though I don't have Garamond installed, yet).

I can't think of anything else which might be relevant...  If I do, I'll add a comment.
Comment 4 Luke Kendall 2015-11-11 02:14:22 UTC
I closed and reopened the document today; and found that many of the comments that I copied across, at the start of the document, are once again appearing in 12 point.  I have lost count of the number of times I have selected "Format All Comments" and selected 10 point.  LO appears to revert the font size to the default of 12 for some comments.

On inspection, the first 11 comments by my editor (which I copied across into my under-revision document) had reverted to 12 pt; these are largely interleaved with my own comments (which are still 10 pt). The on the 7th page, the 1st comment on the page (my editor's copied), is 10 pt; the 2nd comment (my editor, copied) is 12 pt.
For the next 11 pages, all comments are 10 pt; then one of my editor's, on p18, is again in 12pt.  Likewise his next 3 comments (mine, interleaved are 10 pt).  Then all comments are in 10 pt for a few pages.

And so on.  It appears to be random.

I then once again selected "Format All Comments" and selected 10 point.  Ithen scanned through the document, and checked perhaps 100 comments across a hundred or so pages, and all seemed to be 10 pt as you would expected.  I then saved and closed an re-opened it.

At that point LO crashed.  A panel popped up saying "Due to an unexpected error, LibreOffice crashed.  All the files you were working on will now be saved." etc.

LO did not successfully save the changes, nor did it even appear ti notice that the document wa open (it was not recovered).  Anyway, I just re-opened the file, and saw once again that the comments were of varying size, and selected one and did the Format All Comments again to set them all to 10 pt and saved it again.  This time it worked, and I skimmed around and all comments appeared to be 10 pt.  I then closed it and reopened it, and it looked like exactly the same comments which had been 12 pt, were once more 12 pt - as if the Save had not saved the format change.

I made an edit to the main document, and repeated the Format All Comments and re-saved.  That also made no difference: none of the format changes to the comments had been saved.
Comment 5 Luke Kendall 2015-11-14 11:03:57 UTC
I think I understand why some of the comments were 10 pt, and others 12 pt, despite using Format All Comments and setting them to 10pt, then saving the doc:

Method 1)
Change the font size of all comments in the doc via Format All Comments.  All comments change and are displayed correctly at the new size.
But that font size change appears never to be saved.

Method 2)
Manually select all the text in a individual comment and choose 10 pt, and save.
That change *is* correctly saved.

So the reason that it appeared that some comments (randomly) were the correct size, and others weren't, is because every now and then I would change the font size for a new comment I copied across, by using Method 2.  Mostly, however, i used Method 1.

Method 1 simply doesn't work.

I'll submit a separate bug for this if you think it is probably not related to the font size change upon copy.  (I suspect it's a separate bug.)
Comment 6 Buovjaga 2015-11-14 18:00:31 UTC
Thanks for the info in comment 5.

I observed the following:
After using Method 1, saving and reloading, only the comment where I selected "Format all comments" stayed with the modified font size.
It seems this is reported as bug 91596
Comment 7 Timur 2017-04-20 16:10:59 UTC
Seems to me like there were 2 issues here: 
- basic that is duplicate of Bug 103064 (newer but with more useful comments)
- workaround that was fixed in bug 91596. 

If you disagree, please explain.

*** This bug has been marked as a duplicate of bug 103064 ***