Bug Hunting Session
Bug 95289 - The display of mathematical formulae is erroneous in LibreOffice Writer documents.
Summary: The display of mathematical formulae is erroneous in LibreOffice Writer docum...
Status: RESOLVED DUPLICATE of bug 76239
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-24 08:39 UTC by tbenke
Modified: 2015-10-28 22:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the display error (382.83 KB, image/jpeg)
2015-10-24 08:39 UTC, tbenke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbenke 2015-10-24 08:39:03 UTC
Created attachment 119918 [details]
Screenshot showing the display error

I opened some, recently created (and edited) .odt and .sxw documents, that contained mathematical equations, with the Libre Office 4.4.5.2 Writer program (Hungarian language), on a legal Windows 7 Professional (SP1) system.

As it can be seen on the attached image, if we format the entire text of the .odt document either to "Times New Roman" or "Linux Libertine G" typefaces, the mathematical expressions are displayed in an erroneous format.

I think, that the error is independent from the formatting typeface of the surrounding text. I made a reset in the character formatting dialog box of the Libre Office Math equation editor, however, I haven't modified any setting there before, so all character settings were default befor "resetting" them. The error still occurs.

So the error is, that some characters (mostly greek letters and operators) have bad format in the equations.

A more unambiguous example: if I open Libre Office Math editor independently from Writer (version: 4.4.5.2; build: a22f674fd25a3b6f45bdebf25400ed2adff0ff99; locale: hu_HU), and type the equation 1 + 2 = 3, the operators are displayed erroneously.

(I made an issue on the Hungarian LibreOffice dashboard, on the 30th August, 2015.: http://bug.openscope.org/browse/OOO-1019, but they have done nothing regarding it.)
Comment 1 Jacques Guilleron 2015-10-24 12:45:57 UTC
Hi tbenke,

OpenSymbol font is it installed on your computer?
Comment 2 tbenke 2015-10-25 07:19:09 UTC
(In reply to Jacques Guilleron from comment #1)
> Hi tbenke,
> 
> OpenSymbol font is it installed on your computer?

Hi Jacques,
I checked, and OpenSymbol is not installed.

I have a laptop with an Ubuntu system, and the LibreOffice there displays the equations well. I checked, and the OpenSymbol font is installed on that machine.

Maybe the installation program for the LibreOffice 4.4.5.2 Hungarian distribution did not contain this font?

I uninstall LibreOffice from my Windows machine right now, and download it from the Hungarian project page again: http://hu.libreoffice.org/letoeltes/?type=win-x86&version=4.4.5&lang=hu

The exact download location is:
http://download.documentfoundation.org/libreoffice/stable/4.4.5/win/x86/LibreOffice_4.4.5_Win_x86.msi

After installation, the program information is:
version: 4.4.5.2
build id: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
locale: hu_HU

So identical with the removed one. If I check for updates, it says, that it is the most recent version.

Now I open the Math equation editor, and I see perfectly formatted equations.

I go into C:\Windows\Fonts, and now the OpenSymbol (normal) font is installed.

I can't find out, why the OpenSymbol font wasn't installed during the previous installation with the (theoretically) same installer?

Thanks for the hint, with best regards: tbenke
Comment 3 Jacques Guilleron 2015-10-26 16:39:59 UTC
Thank you for the feedback, tbenke.
This can be useful to know that this happens during install without obvious reason. The last time I have ssen this behaviour, font was really missing.
I set status to RESOLVED WORKSFORME.

Have a nice day
Comment 4 Maxim Monastirsky 2015-10-28 22:37:47 UTC

*** This bug has been marked as a duplicate of bug 76239 ***