Bug Hunting Session
Bug 95290 - Libreoffice crashes when trying to export as PDF
Summary: Libreoffice crashes when trying to export as PDF
Status: RESOLVED DUPLICATE of bug 94936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-24 08:48 UTC by drunken monkey
Modified: 2015-10-24 16:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace for the crash (1.70 KB, application/gzip)
2015-10-24 11:36 UTC, drunken monkey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description drunken monkey 2015-10-24 08:48:56 UTC
Steps to reproduce:
- Create or open any document in any Libreoffice application
- Click "Export Directly as PDF"

Expected result:
- Popup opens for selecting the save location

What actually happens:
- Application crashes (all windows are immediately closed without any error popup or the like)
- The following is printed to standard error:

----
(soffice:4543): Gtk-CRITICAL **: gtk_entry_set_text: assertion 'GTK_IS_ENTRY (entry)' failed

(soffice:4543): Gtk-CRITICAL **: gtk_entry_set_text: assertion 'GTK_IS_ENTRY (entry)' failed

(soffice:4543): Gtk-CRITICAL **: gtk_widget_grab_focus: assertion 'GTK_IS_WIDGET (widget)' failed

(soffice:4543): Gtk-CRITICAL **: _gtk_file_chooser_entry_set_base_folder: assertion 'GTK_IS_FILE_CHOOSER_ENTRY (chooser_entry)' failed

(soffice:4543): Gtk-CRITICAL **: gtk_entry_get_text: assertion 'GTK_IS_ENTRY (entry)' failed

(soffice:4543): Gtk-CRITICAL **: gtk_entry_get_text: assertion 'GTK_IS_ENTRY (entry)' failed
----

This worked for me at least until two months ago but now stopped working.
Please tell me if there's a way to get more debug output, or to help in any other way!

Also, I'm normally reluctant to increase the severity on bugs, but found it justified here. If that was incorrect, I apologize in advance.
Comment 1 drunken monkey 2015-10-24 08:51:32 UTC
Oh, forgot to mention: I'm using Arch Linux (4.2.3-1), Libreoffice version is reported as "5.0.2-3" in Pacman.

(Oh, and disregard my "severity" comment, seems I can't increase that anyways. I has it set to "major".)
Comment 2 drunken monkey 2015-10-24 09:02:47 UTC
It seems the same thing happens when trying to "Save As …", do a first "Save" or, presumably, in all other cases where it tries to open any kind of "choose save location" dialog. The standard error output is the same in all cases.

Opening a file through the "Open File" dialog works, though.

I tried a few other programs, but the "Save As …" dialogs work fine, there, so at least it's not a system-wide problem.
Comment 3 Julien Nabet 2015-10-24 11:18:46 UTC
Have you installed some extensions recently?
If yes, uninstall them and give it a new try.

If no, rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give a new try.

If you still reproduce the problem, a backtrace would be useful (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 4 drunken monkey 2015-10-24 11:36:34 UTC
Created attachment 119920 [details]
Backtrace for the crash

No, I haven't installed any extensions (at all, I think, and certainly not in the last months), and unfortunately it also happens with a new profile.
The attached backtrace was created with a new profile. Thanks for linking the instructions!
Comment 5 Julien Nabet 2015-10-24 13:27:25 UTC
Taking a look at the bt, it seems due to a LO bug when using gtk3.
Could you do this:
- open a terminal
- export SAL_USE_VCLPLUGIN=gtk
- launch LO from terminal
?
Comment 6 Maxim Monastirsky 2015-10-24 16:51:00 UTC

*** This bug has been marked as a duplicate of bug 94936 ***