Download it now!
Bug 95338 - Not plausible behaviour when combining cells
Summary: Not plausible behaviour when combining cells
Status: RESOLVED DUPLICATE of bug 30456
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-26 19:57 UTC by Helmut Leininger
Modified: 2016-07-19 15:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of merged cells used as individual in a formula (12.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-19 15:50 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2015-10-26 19:57:36 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: LibreOffice 5.0.3.1

When some cells are combined, the result of calculations using these cells is not plausible (and different from old behaviour / Excel behaviour). Probably, this should be regarded as regression.

Reproducible: Always

Steps to Reproduce:
1. create a spreadsheet, fill Cells B1 through B8 with the values from 1 to 8
2. insert the formula "=SUM(B1:B8)" into cell D8
3. D8 shows the value 36

Example 1:
combine cells B2 through B5 and use default option no0 for moving the contents to the first cell.
Result:
the combined area show the value 2, D8 still shows 36 (which does not relfect what you see and probably would expect)
the values in B3 to B5 are maintained but hidden, nevertheless used in the computation.

Example 2:
combine cells B2 to B5 and use the option yes for moving the contents to the first cell
Result:
the combined area shows "2 3 4 5", D8 shows 22 as sum (which probably would not be expected either)
the content of cell B2 is changed from numeric to a text and therefor not included in the sum, cells B3 to B5 are cleared

Old (an Excel) behaviour:
when combining cells B2 through B5, the value in B2 is maintained, cells B3 throght B5 are cleared. The combined area shows 2, D8 shows 24 as sum (which matches what you see).



[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 m.a.riosv 2015-10-26 22:46:18 UTC
Please take a look:

https://bugs.documentfoundation.org/show_bug.cgi?id=30456
Comment 2 Helmut Leininger 2015-10-27 07:07:48 UTC
If the conclusion is "works as designed", there should be a third option "keep value of first cell, clear other cells" mimicing the behaviour of Excel ...
Comment 3 Thomas Hackert 2015-10-27 17:41:50 UTC
Hello Helmut, *,
I can confirm this bug with LO
Version: 4.3.7.2
Build-ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
(parallel installed, following the instructions from
https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

Version: 4.4.6.2
Build ID: 008d5d0ddffba0b82de2a2c36a65b9cba0a6b328
Locale: de_DE.UTF-8
(also parallel installed)

and

Version: 5.0.2.2
Build-ID: 00m0(Build:2)
Gebietsschema: de-DE (de_DE.UTF-8)

all three under Debian Testing AMD64 and with Germanophone lang- as well as helppack. As I can reproduce this with 4.3.7.2, I will set the earlies to this version.
Sorry for the inconvenience and have a nice evening
Thomas.
Comment 4 WoSch 2015-11-04 11:04:39 UTC
Thanks 4 Publishing These bug. 

If it works as designed I would like to see an example showing a goog reason justifying this Point. 

In my opinion cells covered by merging a couple of cells shouldn't be terms of calculation in function/formula. 

Results of LibO Calcs operations must be the same as results by calculation in mind the cells I see - doesnt' care wether using A1+A3+A4 or SUM (A1:A4) or functions like COUNTIF, COUNTBLANK, AVERAGE etc.

(In reply to Helmut Leininger from comment #2)
> If the conclusion is "works as designed", there should be a third option
> "keep value of first cell, clear other cells" mimicing the behaviour of
> Excel ...
Comment 5 Laurent BP 2016-07-19 15:50:17 UTC
Created attachment 126304 [details]
Example of merged cells used as individual in a formula

(In reply to WoSch from comment #4)
> Thanks 4 Publishing These bug. 
> 
> If it works as designed I would like to see an example showing a goog reason
> justifying this Point. 
You need to keep cells content if you want to keep information about a key used during sort for instance, or used in a formula. See attached example.
Comment 6 Laurent BP 2016-07-19 15:50:58 UTC

*** This bug has been marked as a duplicate of bug 30456 ***