Bug 95343 - Pasting text from Wine apps into LibreOffice 5.x broken in GTK3 interface
Summary: Pasting text from Wine apps into LibreOffice 5.x broken in GTK3 interface
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
Depends on:
Blocks: GTK3
  Show dependency treegraph
Reported: 2015-10-26 21:43 UTC by S.
Modified: 2016-10-18 13:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description S. 2015-10-26 21:43:14 UTC
Pasting from Wine programs into LibreOffice 5.x with the default GTK3 interface usually doesn't work. However on the same system, pasting from the same Wine program into LibreOffice with "SAL_USE_VCLPLUGIN gtk" works correctly every time. 

Additionally, trying to paste from Wine into LibreOffice 5.x with the GTK3 interface frequently caused LibreOffice to crash.

I'm using LibreOffice 5.0.2 on Manjaro Linux (Arch derivative) with the Cinnamon desktop environment. 

By the way, I tried this with and without a clipboard manager like Clipit running, and it makes no difference.
Comment 1 Buovjaga 2015-11-03 09:50:03 UTC
On Ubuntu with libreoffice-gtk3 installed, I launched it with SAL_USE_VCLPLUGIN=gtk3 lowriter

I had installed Abiword in Wine and copied text from it just fine to LibreOffice.

Ubuntu 15.10 64-bit 
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)
Comment 2 Caolán McNamara 2016-03-09 17:19:41 UTC
Might simply be a matter of 5.0.X not having enough implemented yet wrt cnp. How about in 5.1.X ?
Comment 3 Xisco Faulí 2016-10-10 11:24:47 UTC Comment hidden (obsolete)
Comment 4 Caolán McNamara 2016-10-18 13:44:53 UTC
Yeah, installed wine and double checked. It works now in 5.1 onwards. I bet it was just not implemented yet at the time of initial testing.