Download it now!
Bug 95381 - FORMATTING: Autocorrect, changing 2 hypens to 1 em-dash
Summary: FORMATTING: Autocorrect, changing 2 hypens to 1 em-dash
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-28 08:20 UTC by peter josvai
Modified: 2016-09-12 20:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2015-10-28 08:20:37 UTC
Writing with Libreoffice Writer made me accustom to the behavior of this replacement... whenever I want to use an em-dash, I'll do my obligatory rounds, and it feels extremely stupid...

note:
I don't expect Writer to change ONE hyphen to an em-dash at all... 

what I'd expect is that when typing 2 hyphens it'd be changed into an em-dash.. without any considerations :)  but it is NOT happening...

strangely enough, on Linux (mint 17.2), it works like charm..
hitting 2 hyphens generates an em-dash, and THAT'S the thing...
the thing what a writer would expect when writing with Writer :)

as of now, when I type -- and one space after, NOTHING happens...
I'll have to type another character(or string) PLUS one space, and then it'd change... which, I think, is bad behavior...

I also don't like that after an end quote an em-dash is impossible (the change will never happen)... but that is another (important) thing..
that is, I'd expect 2 hyphens to be changed into an em-dash even if there's and end-quote before the 2 hyphens...


- - - -  
to put it simple, I'd expect "hyphenhyphen" to be replaced with "em-dash" right after one space is typed after the second hyphen...


I'd even expect an option in the config options to decide whether this change would happen ON hitting the second hyphen.. or only after a space has been typed... (both versions has advantages, without waiting for another space allows writers to use em-dash without framing spaces, which is the original use of em-dashes, I believe; the second, waiting for a following space allows 3 hyphens to be replaced to a one size greater dash)



Of course, we (you) should first agree on what behavior would be the most ergonomic...

thanks for your work!
Comment 1 Buovjaga 2015-11-08 17:29:17 UTC
Works for me.
Two hyphens produce an em-dash, even if it comes after an end quote like "word" --

There must be some problem with your setup.

Maybe try this: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile

Also, you didn't mention, which LibreOffice version you are using.
I assume you are using Windows.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists after reset and you provided all the missing info. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 6da681442b17c723f9408a806e8d2367441ad65a
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-07_23:13:46
Locale: fi-FI (fi_FI)
Comment 2 tommy27 2015-11-28 08:39:35 UTC
take a look at Bug 67364 and specifically at the last comments

you can customize your autocorrect replacements with wildcards and emojis to achieve the desired result

tell if that link helped you or not
Comment 3 tommy27 2015-11-29 19:37:09 UTC
also remember that there are AutoCorrect options about dashes replacement.
read here:
https://help.libreoffice.org/Common/Options_3#Replace_Dashes
Comment 4 Xisco Faulí 2016-09-11 21:21:19 UTC Comment hidden (obsolete)
Comment 5 peter josvai 2016-09-12 15:07:45 UTC
hi Buovjaga & Tommy27, 


in very short: it is NOT A BUG


before sending my reply I checked the this behavior on my sister's machine, win7, 64 bit, too...
Libreoffice 5.1.7
AND it works perfectly... even "A, quote, space, minus, minus, space" will turn into an en-dash...

so, it seems to be specific to this machine...

then I installed a new windows user, logged in to that profile, and opened Writer, and it works PERFECTLY, too... (the same machine, same OS)

So, sorry for taking your time!!!
I practically can't believe this -- but this is my problem :) 

for my excuse: I did have the problem on two independent win7 machines...
and I still do :) 

but, for sure, Libreoffice works as expected on this machine, under this OS, too.

sorry once again, and THANK you.
Comment 6 peter josvai 2016-09-12 15:21:16 UTC
one last word :)

as stupid as it sounds, I had turned off "use replacement table"...
for some reason...

at the same time, the "replace dashes" option was checked...

I hoped that this replacement would work by itself...

(actually, it does, exactly like it is written in the libreoffice help "replace dashes" section)

However, I'd prefer if it worked like unconditionally, whenever I type "space, minus, minus, space"...
Well, it works as long as the replacement table is turned ON...
cause the first item to be replaced is the "minus, minus" to "en-dash"...


thank you all, and sorry for taking your time
Comment 7 Buovjaga 2016-09-12 20:09:03 UTC
Don't be sorry, it's ok.

What takes time is people cursing us and writing essay-long replies on why they refuse to do further testing we ask from them and expect us to do the testing ourselves for free.