Bug 95456 - When exporting PDF entry without ".pdf" is created under "Recently Used"
Summary: When exporting PDF entry without ".pdf" is created under "Recently Used"
Status: RESOLVED DUPLICATE of bug 37219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-30 21:46 UTC by bug.gefunden
Modified: 2022-12-15 13:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bug.gefunden 2015-10-30 21:46:06 UTC
1. In Writer choose File / Export as PDF...
2. Click "Export"
3. As filename type in "test"
4. Click "Save"

Now a File test.pdf has been created.

Expected Behaviour:
In Gnome and Mate under Places / "Recent Documents" an entry with "test.pdf" is created.

Actual Behaviour:
In Gnome and Mate under Places / "Recent Documents" an entry with "test" is created.

Additional Info: The recently used files are stored in .local/share/recently-used.xbel

So it seems the bug is, that Writer stores the typed in basename under recently used instead of the actual filename that is created.

When typing in "test.pdf" instead as "test" as filename, the correct entry "test.pdf" is stored in recently used files.
Comment 1 Buovjaga 2015-11-09 10:55:09 UTC
Ok I verified from .local/share/recently-used.xbel that it is stored without the extension.

Ubuntu 15.10 64-bit 
Version: 5.0.2.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)

But this is a dupe.

*** This bug has been marked as a duplicate of bug 66412 ***
Comment 2 Mike Kaganski 2022-12-15 13:42:40 UTC

*** This bug has been marked as a duplicate of bug 37219 ***