Bug Hunting Session
Bug 95461 - When printing distorded characters appear on top left corner of page
Summary: When printing distorded characters appear on top left corner of page
Status: RESOLVED DUPLICATE of bug 94428
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-31 00:13 UTC by Hugo
Modified: 2015-11-11 11:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF showing distorted characters at top left corner (375.16 KB, application/pdf)
2015-10-31 00:19 UTC, Hugo
Details
PDF showing distorted characters at top left corner (36.10 KB, application/pdf)
2015-10-31 00:19 UTC, Hugo
Details
Original file (24.57 KB, application/vnd.oasis.opendocument.text)
2015-10-31 09:38 UTC, Hugo
Details
Modified file (70.54 KB, application/vnd.oasis.opendocument.text)
2015-11-02 17:58 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hugo 2015-10-31 00:13:02 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: LibreOffice 5.0.2.2

I experienced this problem with Writer, Calc and Impress (the most affected one), but Draw seems to print just fine. Anyways, when I print something, there's this distorded characters which appear at the top left corner of the page, the actual text from the document is not affected. also the software slows down when I open the prin dialog.

I'm using Windows 10 Pro 64bits (clean install) + a brother dcp-j725dw printer

This also happens if I print to PDF or XPS using windows built in converters, only way to get a clean print at the moment is to use feature 'export directly to PDF' and then print from the PDF file.

Reproducible: Always

Steps to Reproduce:
0. with any open file big or small
1. select print
2. change printer settings
3. press print
Actual Results:  
Print foreign characters on top left corner

Expected Results:  
Only print the actual text from Doc, no added strange characters

[Information automatically included from LibreOffice]
Locale: en-GB
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Hugo 2015-10-31 00:19:26 UTC
Created attachment 120131 [details]
PDF showing distorted characters at top left corner
Comment 2 Hugo 2015-10-31 00:19:42 UTC
Created attachment 120132 [details]
PDF showing distorted characters at top left corner
Comment 3 Jacques Guilleron 2015-10-31 09:19:52 UTC
Hi hugh650,

Can you provide the original odt files, please?
Comment 4 Hugo 2015-10-31 09:38:38 UTC
Created attachment 120135 [details]
Original file
Comment 5 Hugo 2015-10-31 09:41:08 UTC
(In reply to Jacques Guilleron from comment #3)
> Hi hugh650,
> 
> Can you provide the original odt files, please?
 
Please see last file attached.
Comment 6 Jacques Guilleron 2015-11-02 17:58:58 UTC
Created attachment 120208 [details]
Modified file
Comment 7 Jacques Guilleron 2015-11-02 18:01:24 UTC
Hi, 

I chnaged "line return" by "Paragraph mark".
Does this change something in your exports?
Comment 8 Hugo 2015-11-02 19:59:47 UTC
Hi, I tried printing and exporting the modified file but problem persists.
Comment 9 Jacques Guilleron 2015-11-03 13:24:57 UTC
Can you try this:

Uncheck "Use of OpenGL for all rendering" from
Tools > Options > LibreOffice > View: Graphics Output
and tell if this change sommething?

Thank you
Comment 10 Hugo 2015-11-03 20:21:18 UTC
Hi there, i tried chaging the settings like you suggested but no, problem still there, i noticed is possible to copy the letters on the pdf export, 'aXDm!Y"E#nZF$o[G\%p]Hq^&rI'sJ(`tK)au*Lbv+Mcw,d-Nx.e/yOf0zgP1{h2|Q}i3j~RkÄST UVW' this is what is squashed at top left corner. any clue as to what might be generating this?
Comment 11 Buovjaga 2015-11-11 11:59:55 UTC

*** This bug has been marked as a duplicate of bug 94428 ***