Bug Hunting Session
Bug 95504 - Libreoffice crashes when trying to save file
Summary: Libreoffice crashes when trying to save file
Status: RESOLVED DUPLICATE of bug 94936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-11-01 17:32 UTC by Martin Marmsoler
Modified: 2015-11-02 09:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Log of the crash when saving document (11.25 KB, text/plain)
2015-11-01 20:08 UTC, Martin Marmsoler
Details
Screenshot of the paths (167.24 KB, image/png)
2015-11-01 20:59 UTC, Martin Marmsoler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Marmsoler 2015-11-01 17:32:11 UTC
My Libreoffice 5.002 crashes every time when I try to save a new Document. I use Antergos
Comment 1 Julien Nabet 2015-11-01 17:51:43 UTC
On which env are you? (Windows, MacOs, Linux)
Do you try to save on a local disk or on network share?
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give a new try?
Comment 2 Martin Marmsoler 2015-11-01 18:03:43 UTC
I use Antergos which base on Arch Linux. I clicked on save as... then the programm chrash. Also when I use the shortcut strg+s without a dialog where I would save
Comment 3 Julien Nabet 2015-11-01 18:06:46 UTC
Ok so you're on Linux.
Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give a new try?

If you still reproduce this, could you try to get a backtrace if possible? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 4 Martin Marmsoler 2015-11-01 18:13:49 UTC
But where I can find the .log file?
Comment 5 Julien Nabet 2015-11-01 18:39:37 UTC
(In reply to Martin Marmsoler from comment #4)
> But where I can find the .log file?

It isn't in the directory from where you launched soffice?
Comment 6 Martin Marmsoler 2015-11-01 20:08:08 UTC
Created attachment 120175 [details]
Log of the crash when saving document

Here the Log file
Comment 7 Julien Nabet 2015-11-01 20:24:36 UTC
Could you run:
export SAL_USE_VCLPLUGIN=gtk
then try again?
Comment 8 Martin Marmsoler 2015-11-01 20:43:04 UTC
No it didn't changed anything
Comment 9 Julien Nabet 2015-11-01 20:46:47 UTC
Just to be sure, did you rename your LO directory profile and give a try?
Comment 10 Martin Marmsoler 2015-11-01 20:59:20 UTC
Created attachment 120180 [details]
Screenshot of the paths
Comment 11 Julien Nabet 2015-11-01 21:02:37 UTC
(In reply to Martin Marmsoler from comment #10)
> Created attachment 120180 [details]
> Screenshot of the paths

I just meant to try this:
mv ~/.config/libreoffice ~/.config/libreoffice_backup

The goal is to force LibreOffice to create a brand new LO profile so we'll know if the problem was due to something wrong in your LO profile or not.
Comment 12 Martin Marmsoler 2015-11-01 21:07:02 UTC
No same problem.
Comment 13 Julien Nabet 2015-11-01 21:10:09 UTC
Ok thank you for your feedback.
Since I don't have more questions + there's a bt, let's put this one to NEW.
Comment 14 Maxim Monastirsky 2015-11-02 09:55:17 UTC

*** This bug has been marked as a duplicate of bug 94936 ***