Bug Hunting Session
Bug 95514 - Can not copy "value only" from calculated range to other range (it show all value in a cell)
Summary: Can not copy "value only" from calculated range to other range (it show all v...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2015-11-02 07:36 UTC by btx_xx
Modified: 2016-10-19 21:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example table and details of problem (154.54 KB, application/vnd.oasis.opendocument.text)
2015-11-11 07:38 UTC, btx_xx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description btx_xx 2015-11-02 07:36:51 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
Build Identifier: LibreOffice 5.0.2.2

In writer when I want to copy value from calculated cell to other cell, it can paste to "value" in new cell. but when I copy multiple cell, it can not paste to new range in "value only" format. It can do copy formula format.

Reproducible: Always

Steps to Reproduce:
1.add value in table such as in column a (=1) and b(=2).
2.use "F2" to add formula in column c such as "=a+b" it will show value "3"
3.repeat to have more row
4.copy all row in column c
5.select all row in column d
6.paste by "paste menu (right click)" or "ctrl+alt+v" or "menu bar"
Actual Results:  
if choose only a destination cell with "unformated text paste" it show all value in that cell,
if choose all row (range) with "unformated text paste" it show all value in that range,
if choose other type it show error in formula or mistake value (becuase its formula).

Expected Results:  
show "value" (that I see in copied range) in destination range (each value in each cell).

[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 A (Andy) 2015-11-07 08:43:10 UTC
I am not sure if I understand your issue right.  But from my point of view this is no bug.  

If you select a cell with a formula and copy it to another cell then the formula is also copied (see https://help.libreoffice.org/Calc/Copying_Formulas).  

If you want to copy only the value itself, but not the formula (because the copied formula will calculate a new value) then you need to choose EDIT -> PASTE SPECIAL and click OK (pay attention FORMULAE is not checked).  In addition, you could insert a copied value with a right mouse click and then go in the context menu to PASTE ONLY -> NUMBER. 

Does this explanation already solve your issue?
Comment 2 btx_xx 2015-11-11 07:38:45 UTC
Created attachment 120472 [details]
example table and details of problem

explain the details of problem in the example table
Comment 3 btx_xx 2015-11-11 08:18:39 UTC Comment hidden (no-value)
Comment 4 btx_xx 2015-12-04 02:08:05 UTC
anyone can help me?
Comment 5 Yousuf Philips (jay) (retired) 2016-10-19 21:39:44 UTC
Hi btx_xx,

Thank you for reporting the bug. I tested attachment 120472 [details] and your expectation that pasting into column D would retain the same formula as when in it was copied from column C is incorrect and not how Calc works either. Writer's tables function differently to Calc's cells, so this isnt a bug.