Bug 95528 - HELP VIEWER: Visibility attribute of <variable> tag not honored
Summary: HELP VIEWER: Visibility attribute of <variable> tag not honored
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Help-Viewer
  Show dependency treegraph
 
Reported: 2015-11-02 18:45 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-09-30 17:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot of example (36.29 KB, image/png)
2015-11-02 18:45 UTC, Yousuf Philips (jay) (retired)
Details
Screenshot with LO5.1 on Windows (43.45 KB, image/png)
2015-11-02 22:21 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-11-02 18:45:49 UTC
Created attachment 120209 [details]
screenshot of example

The help viewer doesnt honor the visibility attribute of the <variable> tag, like it does for the <ahelp> tag. Here is an <variable> tag example from the help authoring tool pdf on page 69.

<comment>List of menu names to be embedded</comment>
<paragraph xml_lang="en-US">
<variable id="menu_File" visibility="hidden">File Menu</variable>
<variable id="menu_Edit" visibility="hidden">Edit Menu</variable>
<variable id="menu_View" visibility="hidden">View Menu</variable>
</paragraph>
Comment 1 Yousuf Philips (jay) (retired) 2015-11-02 19:13:10 UTC
Its a regression as it doesnt happen in 3.3.0 and 4.2.8.
Comment 2 Yousuf Philips (jay) (retired) 2015-11-02 19:18:05 UTC
My mistake, its inherited from OOo.
Comment 3 Regina Henschel 2015-11-02 22:21:53 UTC
Created attachment 120215 [details]
Screenshot with LO5.1 on Windows

Are you sure, you use a current version? For me it looks like the attached screenshot. I have made it with Version: 5.1.0.0.alpha1+
Build ID: 2511a21841dd9dec735a53add8174e47d24deb88
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-13_23:26:46
Locale: de-DE (de_DE)
Comment 4 Regina Henschel 2015-11-02 22:30:37 UTC
Or do you mean you have inserted that text? It seems, that no such <variable> elements exists in the current files. Or do you know a file where it is used?
Comment 5 Yousuf Philips (jay) (retired) 2015-11-03 13:38:53 UTC
(In reply to Regina Henschel from comment #4)
> Or do you mean you have inserted that text?

Yes i inserted the example xml into the help file to show in the screenshot.

> It seems, that no such
> <variable> elements exists in the current files. Or do you know a file where
> it is used?

I plan to use them in future commits and noticed that it was not working.
https://gerrit.libreoffice.org/#/c/19745/
Comment 6 Olivier Hallot 2017-12-10 13:37:58 UTC
(In reply to Yousuf Philips (jay) from comment #5)

> I plan to use them in future commits and noticed that it was not working.
> https://gerrit.libreoffice.org/#/c/19745/

Hi 
The patch is marked Abandoned.

Closing the bug, marking invalid.
Comment 7 Yousuf Philips (jay) (retired) 2017-12-10 22:39:27 UTC
(In reply to Olivier Hallot from comment #6)
> The patch is marked Abandoned.

The patch wasnt to fix the broken behaviour of the help viewer, so this bug still exists.
Comment 8 Buovjaga 2020-09-30 17:04:15 UTC
Help viewer is not being developed anymore, so closing