Bug 95545 - WordPerfect 5.1 file imported but text with Courier font not displayed
Summary: WordPerfect 5.1 file imported but text with Courier font not displayed
Status: RESOLVED DUPLICATE of bug 98989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-11-03 16:25 UTC by Marcin Miłkowski
Modified: 2016-05-11 14:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
WordPerfect 5.1 that cannot be imported. (3.67 KB, application/vnd.wordperfect)
2015-11-03 16:25 UTC, Marcin Miłkowski
Details
console logs (1.47 KB, text/plain)
2015-11-03 20:25 UTC, Julien Nabet
Details
expected libwpd's converted file (13.36 KB, application/vnd.oasis.opendocument.text)
2015-11-06 08:53 UTC, osnola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Miłkowski 2015-11-03 16:25:35 UTC
Created attachment 120228 [details]
WordPerfect 5.1 that cannot be imported.

WordPerfect 5.1 files that were opened in older versions of OpenOffice / Libreoffice no longer open correctly. Note: nothing even appears, not a single message.

Another extremely strange thing is that the very same file does open in AbiWord which uses supposedly the same import library (libwpd). But if you try to copy and paste a document, nothing will get pasted.

To reproduce:

1) Open the file attached.
2) LibreOffice cursor icon will turn around.
3) Blank document will appear instead of a page-long document.


I noticed that few WP 5.1 files do open, but this is very rare (I have a huge collection of older documents in WP51 format).
Comment 1 raal 2015-11-03 17:09:02 UTC
I can open file with  5.0.2.2, linux, but not on windows -  LO 5.0.2.2 and Version: 5.1.0.0.alpha1+ (x64)
Build ID: 72f192418948f018f6c8b18c14463476820c9d5b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-10-19_21:22:52

Setting as new, windows only.
Comment 2 Julien Nabet 2015-11-03 20:25:42 UTC
Created attachment 120239 [details]
console logs

On pc Debian x86-64 with master sources updated today, I don't reproduce this (as expected according to Raal's comment).
However, I thought it might be interesting to provide console logs from wpd module. Indeed, we can see the import process.
Comment 3 raal 2015-11-04 08:05:03 UTC
bibisect-win32-5.0, oldest version contains bug too.
git checkout oldest: Version: 4.5.0.0.alpha0+
Build ID: 57d6b92b69a31260dea0d84fcd1fc5866ada7adb

@Marcin, what is last know good version of LO? I can open file in Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 4 David Tardon 2015-11-04 14:56:08 UTC
(In reply to Marcin Miłkowski from comment #0)
> WordPerfect 5.1 files that were opened in older versions of OpenOffice /
> Libreoffice no longer open correctly. Note: nothing even appears, not a
> single message.

This means that the filter works, but produces no output or the output is not valid.

> 
> Another extremely strange thing is that the very same file does open in
> AbiWord which uses supposedly the same import library (libwpd). But if you
> try to copy and paste a document, nothing will get pasted.

That's not strange at all. Your AbiWord can be using an older version of the library, or it builds it differently (I assume libwpd is bundled with AbiWord, just like with LibreOffice), or the problem you see is not in libwpd at all, but in libodfgen or in the interaction with LibreOffice...

> I noticed that few WP 5.1 files do open, but this is very rare (I have a
> huge collection of older documents in WP51 format).

That's really weird. I could imagine libwpd (or libodfgen) being unintentionally broken on Windows, but then it would import no documents. Is this only a problem with libwpd import filter, or do other filters that use the same framework fail as well? There are sample docs available in subdirs of https://gerrit.libreoffice.org/gitweb?p=core.git;a=tree;f=writerperfect/qa/unit/data/writer;h=2e4c58626e1eac2834a9ef0c568539036f9c83a2;hb=HEAD .
Comment 5 raal 2015-11-04 15:53:05 UTC
(In reply to David Tardon from comment #4)
> 
> That's really weird. I could imagine libwpd (or libodfgen) being
> unintentionally broken on Windows, but then it would import no documents. Is
> this only a problem with libwpd import filter, or do other filters that use
> the same framework fail as well? There are sample docs available in subdirs
> of
> https://gerrit.libreoffice.org/gitweb?p=core.git;a=tree;f=writerperfect/qa/
> unit/data/writer;h=2e4c58626e1eac2834a9ef0c568539036f9c83a2;hb=HEAD .

I can open (see the text)
writerperfect_qa_unit_data_writer_libwpd_pass_WP6.wpd
writerperfect_qa_unit_data_writer_libabw_pass_hello.abw
writerperfect_qa_unit_data_writer_libe-book_pass_Broad_Band_eBook.lrf
writerperfect_qa_unit_data_writer_libe-book_pass_Plucker.pdb

but doesn't see the text in file attached to this bug (file is opened empty).
Version: 5.1.0.0.alpha1+ (x64)
Build ID: 72f192418948f018f6c8b18c14463476820c9d5b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-10-19_21:22:52
Comment 6 Marcin Miłkowski 2015-11-05 08:41:16 UTC
(In reply to David Tardon from comment #4)
> > Another extremely strange thing is that the very same file does open in
> > AbiWord which uses supposedly the same import library (libwpd). But if you
> > try to copy and paste a document, nothing will get pasted.
> 
> That's not strange at all. Your AbiWord can be using an older version of the
> library, or it builds it differently (I assume libwpd is bundled with
> AbiWord, just like with LibreOffice), or the problem you see is not in
> libwpd at all, but in libodfgen or in the interaction with LibreOffice...

Of course it's not strange that AbiWord opens these WP51 files. What is strange is that I cannot copy and paste the content of these files from AbiWord to LibreOffice over the clipboard. That's really weird!
Comment 7 Marcin Miłkowski 2015-11-05 09:00:20 UTC
(In reply to raal from comment #3)
> bibisect-win32-5.0, oldest version contains bug too.
> git checkout oldest: Version: 4.5.0.0.alpha0+
> Build ID: 57d6b92b69a31260dea0d84fcd1fc5866ada7adb
> 
> @Marcin, what is last know good version of LO? I can open file in Version
> 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

I tried with 4.4.4.3, and 4.6 Win32, and it didn't work. Will try to go back in time further.
Comment 8 David Tardon 2015-11-05 09:25:51 UTC
(In reply to Marcin Miłkowski from comment #6)
> Of course it's not strange that AbiWord opens these WP51 files. What is
> strange is that I cannot copy and paste the content of these files from
> AbiWord to LibreOffice over the clipboard. That's really weird!

That depends on the format(s) AbiWord offers for clipboard transfer. I doubt WP is among them (and that LibreOffice does support that format for clipboard transfer). Can you copy/paste a newly created text from AbiWord?

I'd say that your LibreOffice installation were damaged, but since you have the same problems with different versions, this is improbable...
Comment 9 osnola 2015-11-06 08:53:08 UTC
Created attachment 120316 [details]
expected libwpd's converted file

Hello,
no problem also on OSX and the libwpd's converted files attached seems very basic excepted that the text is displayed with Courier's font ; so maybe this is related to https://ask.libreoffice.org/en/question/3789/libreoffice-not-recognizing-courier/ or not...
Comment 10 Michael Stahl (CIB) 2016-05-11 14:05:00 UTC
oh fun, another victim of the Windows Courier bug

*** This bug has been marked as a duplicate of bug 98989 ***