Bug 95546 - This .docx file created by LO cannot be opened in MS Word
Summary: This .docx file created by LO cannot be opened in MS Word
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-03 16:43 UTC by Frederic Parrenin
Modified: 2016-07-18 15:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.docx file to reproduce the problem (31.15 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-11-03 16:43 UTC, Frederic Parrenin
Details
the original .docx document before modification in LO (108.38 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-06-30 14:39 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2015-11-03 16:43:56 UTC
Created attachment 120230 [details]
.docx file to reproduce the problem

Steps to reproduce:
- open the attached .docx file in LO
- make a trivial change and re-save the file
- open the file in MS Word (tested with Word 2007)
=> MS Word hangs and cannot open the file

Originally, this file was created from a .docx file (presumably created with MS Word) and modified in LO 5.0.2.
Comment 1 raal 2015-11-03 17:02:39 UTC
(In reply to Frederic Parrenin from comment #0)
> Created attachment 120230 [details]
> .docx file to reproduce the problem
> 
word2010 - unknown error in file. Location: Part:/word/document.xml, Line:2, column: 2175

Part of xml file on Line:2, column: 2175:  <wp:simplePos x="0" y="0"/>

According to http://officeopenxml.com/drwPicFloating-position.php  Note: Microsoft Word seems to not fully support positioning with <wp:simplePos>   maybe bug in word.
Comment 2 Justin L 2016-06-28 13:03:15 UTC
The example document already fails to open in Word even before touching it with LibreOffice.  Can you provide the original that is untainted by LO still?  Is this a duplicate of bug 99090?
Comment 3 Frederic Parrenin 2016-06-30 14:39:02 UTC
Created attachment 126006 [details]
the original .docx document before modification in LO
Comment 4 Justin L 2016-07-18 13:41:42 UTC
This is not a duplicate of bug 99090.

Unable to reproduce.  Tested re-saving the file provided in comment 3 using 5.3dev, 5.1.2, and 5.0.5.  Word 2007 was able to open all of the LO-saved versions of the file.
Comment 5 Frederic Parrenin 2016-07-18 15:38:42 UTC Comment hidden (already_answered, obsolete)